Author Kyle
2005
5
1
Premium
Ambassador
Rank 1
Unfollow

Creating a domain specific email address and email forwards are very easy to do here as a Premium member of Wealthy Affiliate. In this video I am going to walk you through the following:

  1. How to Create a Domain Specific Email Address
  2. How to Access Your Inbox
  3. Managing your Email Accounts
  4. How to Create an Email Forward & the Benefits

If you have any questions about any of the content within this video, please leave it within the comments below and I will be more than happy to help you out.

Join the Discussion
Write something…
Recent messages
CraigO1 Premium
Well I set up the email address as the video shows, but when composing an email and sending to my personal gmail address nothing shows up in gmail. I checked the spam folder. This is not a forward just an email sent from the new domain email I just set up as explained in the video. Any ideas as to what the problem might be?
Reply
MozMary Premium Plus
yes, that is just a webmail

here are the steps for email forward and own domain email remember not to use the same email you just set up - if you want that one then delete it first
Reply
CraigO1 Premium
but not considering a forward as I will do this later I was just testing the email function. I should be able to send an email from my webmail account that I just sent up, correct?
Reply
MozMary Premium Plus
yes, I just tested it and it came in fine to my gmail from webmail, but take a look in All Mail, not just spam

you have to hover round the bottom of the gmail menu on the left to bring up the All Mail button you actually have to bring up the More button and in there All Mail - gmail is a pain in the ass with that
Reply
CraigO1 Premium
The email I sent did finally get delivered but they took about 3 hours. I went ahead and did the forward to gmail and set up alias in gmail and not send and deliver are within a few seconds.

Thanks for your help Mary
Reply
MozMary Premium Plus
wow, great news Craig :)
Reply
Brandview Premium
Ok... this email forwarding is getting to be a bit much... weird and wonderful things happen...
My biggest concern at this moment in time is
A/ If I send myself an email from somewhere else it works fine!...
B/ if I put the email link on my website it opens in a Google Gmail ad!!... tried both main page and Privacy Policy
C/ If I open my site in another computer it then tells me that the account is not properly configured!... I tried two emails from two different domains on WA.

Any suggestions?

Thanx
John@Brandview
Reply
Triblu Premium
Hey John,

Having mulled your questions over during my night’s sleep, trying to figure out the best way to explain this too you without confusing you even more ... I think I may have it ... soooo ... here goes:

Once you are certain that a mailto tag is coded properly, the computer that is used to click on that link needs to have an email program setup and ready for use or the link will not work. This is why it is recommended that we use email forms (covered in detail in Kyle’s training) on our contact page.

Hope this helps you.
Reply
Brandview Premium
Hi Trish...
Thanks for the response...
It's all greek to me... "Mail to Tag Coding"!! etc...
Nah! I'll just trudge along... and one day... the penny will drop.
I am a rather patient fella...and procrastinator etc...

Hope you have a great day!...

Thanx
John@Brandview
Reply
phakacha8 Premium
May be you should link up the support site before inserting email for out ward exposure.
Reply
Triblu Premium
Hey John,

Here's a tutorial that will explain a mailto tag: Learning should be fun ... yes!

Hope this helps you.
Reply
MozMary Premium Plus
here are all the steps you need, make sure you use a different email to the one you just set up or delete that one first if that is the one you want

contact me from within the training for further help, no coding required
Reply
Brandview Premium
Hi Mary,
Thanx for being so helpful...
Deleted everything and followed the instructions to a T...
If I send an email via another mailbox to my forward email address it does so perfectly!. Also setup the return mail to the relevant sender... everything works 100%...
EXCEPT!...
When I insert the LINK in my website I get the message
"Could not perform this operation because the default mail client is not properly installed"
I then tried to make a link(mailto:brandviewmedia@gmail.com) direct to my gmail account and that gives me the exact same message!
So!... it seems the problem exists elseware... BUT where?...
That is the million dollar question!
Hope you have a great day!...

Regards
John@Brandview
Reply
MozMary Premium Plus
where did you try to insert the link in your website?

I just went in to user, create new user and put my domain name in there and got no error message
Reply
Brandview Premium
Hi Mary,
on my Private Policy Page and tried to put my email address on there for people to contact me...
e.g. www.afrenchbulldog.com/privacy-policy/
See if you can mail me from there...
Regards
John@Brandview
Reply
Triblu Premium
Just sent you a test message John.
Please, let me know if you received it or not.
Reply
Brandview Premium
Hi Trish,
Thanks for that... No I did not receive it
But the question is... did you not get a message saying that the page is not setup correctly?
Which link did you use? the one in the post below?
www.afrenchbulldog.com/privacy-policy/
and the link on the first paragraph which says...
A French Bulldog Helpdesk

Thanx
John@Brandview
Reply
Triblu Premium
No I didn't get any such prompt John, as your link (a mailto tag) opened an email message using my computer's installed email program and NOT an online email account.

Maybe my test message is in your junk folder ... maybe.

The email link I used is shown in the screen print below...
Reply
Brandview Premium
Thanx Trish... maybe you could try it again...
I do clean out that email sometimes with just a quick glance before, so maybe i missed it.
This whole exercise is all still in guinea pig mode...
regards
John@Brandview
Reply
1signbanner Premium
Hi anybody, so I have created my new domain-email address/account (i'm sorry if you below have already answered this question it's just there is soo much information going thru my braincells my focus is all over the place.

So if i get a response from my domain, I get it thru my email....correct!? Now if I have another domain and use my domain-email it can come thru too me. Not a good idea have 2 domains with one domain-email.

Kyle mentioned something about I was not "clear" what he said, can somebody I prefer a human give me council on this.

Thank you soooo much ....anyone!

signbanner
Reply
MozMary Premium Plus
this will show you all the steps and how many you can do...
Reply
AndyMadsen Premium
Is there any known troubles with non-.com domains?

I have trouble with a .dk domain that is fully hosted using the mywahosting.com domains name servers. I also have a .com domain with same setup and do not notice the same problem.

I am not able to send mail from the .dk to a gmail-account. The account does not recieve anything either. I have also tried echo mailers like echo@tu-berlin.de and ping@stamper.itconsult.co.uk - nothing is pinged back to the .dk-domain. The only thing possible is sending from the .dk to the .com, both domains hosted @ mywahosting.com. I am not able to send reply from the .com to the .dk domain.

How to solve this?
Reply
feigner Premium
Have you tried talking to site support?
I know they don't like to support .co.uk sites here and prefer to support the suffixes they sell, so i wish you well with your problem and hope you can get it sorted.
Phil
Reply
AndyMadsen Premium
Thank you for the answer, feigner.

A lot of tests mails from 3-4 hours ago now start coming in. Seems like there was a delay. Will hold my horses for now. Let's see. I will try support if problem is not fixed.
Reply
feigner Premium
Damn - you mean it is not all instant!! lol
It does take a while sometimes.
Glad it is now working.
Reply
pereirasteph Premium
Hi guys, I'm not sure if i created my email properly? I created an email on the "New Email Mailbox" tab, but when I tried to create on the "New Email Forward Tab', it said first delete your email on the New Email Mailbox tab and then create on the forward tab - which i did and then put in my gmail ID as an email to forward to. However, I tested to see if it would forward to my gmail but it didn't. What am I doing wrong and what can I do to make it right?
Reply
MozMary Premium Plus
yes, you had to delete the webmail to create the email forward of the same name
Reply
pereirasteph Premium
Hi Moz. It's just not reading my email ID for some reason. I followed the steps very closely right until it sent an email to my domain email - the issue is I can't access my domain email when I create it on "New Email Forward", so I'm basically completely stuck cause no emails am i able to access. Your help would be really appreciated in this matter.
Reply
MozMary Premium Plus
it's usually something really simple, I'll PM you in a little while and see which step may be the issue, meanwhile make sure it is all the steps in this [different] training that you've followed and the troubleshooting page at the end ps make sure you created an email forward and not webmail
Reply
pereirasteph Premium
Yes, i followed what you mentioned. Will await to talk privately!
Reply
Top