Trouble uploading images in Wordpress

Last Update: May 08, 2016

Usually, when I want to upload an image or two to Wordpress there are no issues -- they upload just fine.

But sometimes I get an error message: 'An error occurred in the upload. Please try again later'. And I try again later...and later..and later with the same problem. After awhile I don't know whether to abandon the image or just save my post as a draft and try the next day which I hate to do because when I'm at the 'add images' stage I'm on a roll!.

This happens fairly frequently with me ( on different themes too) and is damned aggravating!

Does this happen to anyone else or is it just my bad luck?


Edit: well, I just pressed 'save draft' and my post, with embedded video, dissappeared!

2nd edit: I got it back!

Join the Discussion
Write something…
Recent messages
BarbJaeb Premium
I have had that happen to me a few times with the images and the error message...I always assumed it had something to do with the image, not Wordpress. When that's happened to me, I discarded that image and tried another with success.
Reply
speedicut Premium
I thought it might be the image but when it happens I'll try other images and it still won't work.
Reply
BarbJaeb Premium
hmmmm sorry, I've never had that happen.
Reply
Robert-A Premium
When you click on 'Dashboard' and scroll down you should see your 'Recent Activity'.
I'm signing off now but if you're still stuck get back to me tomorrow.
Robert
Reply
speedicut Premium
I'm good now...thanks Robert!
Reply
cosmicradio Premium
I have lots of trouble adding images to my blogs-very annoying. I'd say about 10-20% of the time the image goes on. Also, can't do multiple images, unless I load them all up at the start. If I find the answer, I'll let you know. (I'm on a 2007 MacBook)-Rick
Reply
speedicut Premium
I think my success rate is about 60 or 70 percent. Looks like it's just an annoyance I'll have to get used to I guess..
Reply
cosmicradio Premium
Your batting average is better than mine! I've been sent back to the Minors. :)
Reply
Robert-A Premium
Did it disappear altogether or is it still showing as a draft when you click on Posts?
If it is and even if there isn't anything showing in Edit Mode you should still have automatic saves with WP. They will show at the bottom of the post page and you just click on one and restore it.
Robert
Reply
speedicut Premium
Thanks Robert - It was saved in drafts luckily!
I might have hit the 'delete' button instead of 'save draft' because they are right next to each other in my theme.
Reply
Chrissies Premium
Sorry you are having these problems.
I haven't had any so far, touch wood!!
I suppose it couldn't be anything to do with the wordpress updates issue?
I hope you manage to sort it out. :)
Reply
speedicut Premium
I managed to get the image uploaded but this happens to me all the time...quite frustrating!
Reply
Chrissies Premium
I really feel for you, we don't need frustration like that when there's so much to do! :)
Reply
Top