About QiMindset
Rank 1038
317 followers Joined October 2021
Hi, I'm Al Perry. I'm an older guy who recently turned 70. I blogged about that here: https://my.wealthyaffiliate.com/qimindset/blog/turning-70-a-right-of-passage I've been helping people manage their pain in

Posts

14

Questions

5

Login
Create Your Free Wealthy Affiliate Account Today!
icon
4-Steps to Success Class
icon
One Profit Ready Website
icon
Market Research & Analysis Tools
icon
Millionaire Mentorship
icon
Core “Business Start Up” Training
asked in
Website Development & Programming

Good Day, my beloved WA family.

I was wondering if anyone used "Elementor" Theme?

I use Thrive Themes currently. I have courses built on my website that are my ma

Hi Al...I'm just reading the thread. I stayed away from it because I had heard it was difficult. But I'm learning a fair bit in the comments below. I hope it all works out for you!

Susan

Thanks Susan!

I'll figure it out eventually then post what I did👍

Keep thriving!

Al

I've thought about it, AL, but had heard that it can be difficult to use, among other things! I hope you get some good answers!

Jeff

Yeah, Jeff, I'm going to wait for the theme support and talk to them before I decide anything.

They're in Germany so I won't hear from them fire awhile.

I'll figure it out, I've had some good suggestions here👍

Thanks fur reaching out, I'll be commenting on your awesome day later on tonight.

Stay well my friend!

Al

You're very welcome, AL, and whenever you can, my friend, is fine!

Keep thriving!

Jeff

Hey Al,

Both of those you mentioned, they are NOT themes but rather pagebuilders.

Pagebuilders can devastate a site when developers desert them. One of my clients who came to me with his site... well, his site had a pagebuilder that the developer deserted once WordPress introduced their Block Editor.

Pagebuilders also add to the time it takes for a page to load, so I'm not surprised to learn that Thrive Themes pagebuilder broke your website.

Have you communicated with Thrive Themes to get their help in fixing your site? They used to be great at the support they offer.

Though after they walked away from properly supporting all of the theme they used to offer... and those that I had purchased from them, I no longer trust them.

Trish, thanks for your response,

It is what I use for my theme. Omni from Thrive Themes.
The Theme isn't the main issue, it's the course-builder plugin.

The courses work well, but about 50% of the time on updates, the code has a flaw in it and it crashes my site.

Support then deactivates the plugin so I get my site back, but no courses until Thrive support fixes the issue on their end.

Anyway, they always do fix the issue, but often it takes some time because of our time differences.

Ahhh... then if the issue is with the plugin, then THAT'S who you need to reach out to... their support, as I'm sure that would be the quickest way.

If it is NOT your pagebuilder that is the issue then changing to Elementor's pagebuilder won't resolve your issue either.

Hope this makes sense.

Creating a backup of your site BEFORE doing updates really can be a website saver. So... next time... right?

It does, but I don't think I can use another course building plug-in that is compatible without changing themes.

This is my issue. I need those courses, they are an essential part of my income!

Whose course builder plugin are you using, if you don't mind my asking you.

Thrive Theme's "Thrive Apprentice"

It's great when it is working!

Ooooh... so, you're using their Architect (pagebuilder) AND their plugin Apprentice. YIKES!

Soooo... how long did they say they would be before repairing their plugin so that your site training will be once again available?

They haven't responded yet. It normally takes 10 - 12 hours, probably because of time difference. They are in Germany. I'm in California.

So you can see why I want to change. I also use their theme, as well as architect and apprentice. The Theme is not a plugin, it's a theme, the only one I have.

Technically, you could use ANY theme when you are using a pagebuilder. And, who knows for certain, their theme MAY be causing you the issue you are experiencing.

I have only one website yet to remove their theme from. That site being my hobby site, I tend to neglect it and their theme has degraded terribly.

It doesn't surprise me, as they announced a few years ago that they would NOT be fixing their themes going forward, NOR supporting them. They've stuck to that promise, of that I can assure you.

Hopefully you can get this fixed. Though once fixed, and in the months to come, I would be giving serious consideration to leaving Thrive products all together, as their support for any of their products are not long lived.

I use Thrive Theme Builder on all 25 of my websites and have absolutely no issues. Which plugins cause the problem when they update?

Also, I believe Elementor is a website design tool, rather than a theme.

I have had this issue mostly with Thrive Apprentice. It is what my courses are built on. I have had it happen with Thrive Architect once, and Thrive Themes twice (I use Omni).

It's always the same issue, A piece of bad code installed in the update.

It's getting old.

I'm glad you have no issues, I have no idea why I do.

I still have a couple of sites with legacy themes (Rise and Luxe) but almost all now use Thrive Theme Builder. You are welcome to look at the sites listed on my profile to see how it looks.

I've started to use Apprentice and have had no issues yet, but it's early days.

I will check them out, Thanks, Phil!

Your sites look great, Phil, you're a master website builder.

I didn't however find any courses, but maybe I didn't look hard enough! 🤣

That's correct. I haven't published any yet. Also, only 7 of my sites are shown on my profile, as that's the most WA allows you to list. I do have sites where you can sign up to be notified of courses when they are published.

I'd have you check mine out, but apprentice is down right now.
I'll let you know!

I contacted thrive themes, perhaps there is something on my site that isn't compatible, if you're not having any issues.

Let me know how it goes, Al. I'd love to check out your site for you.

Will do, Phil, thanks!!

I use Elementor Pro.

However the sensible thing here is to reach out to Site support try find a solution or restore your website to a previous date without the update see if it can be fixed.

Thanks Abie!

Site support is always great.
I always get the issue fixed.

However, sometimes I don't catch it for a few hours.

It usually takes a half day to get help from my theme support as they are in Germany and I am in California. So I could be down a day. That isn't optimum for either selling courses or students taking them after they have paid good money to take them.

I saw that Elementor Pro offered course building. Have you had any issues with it crashing your site when the Theme or its plugins update?

Thanks Abie!

I know that ultimately this will benefit me and my website.

Keep thriving!

Al

I cannot guarantee that it will not crash. However Elementor Pro is a page builder as opposed to a theme.

Also Elementor has been known to slow down websites, however not the case with a premium caching plugin.

Have you considered LifterLMS WordPress plugin for courses, you may check it out here

https://wordpress.org/plugins/lifterlms/
https://lifterlms.com/

That's the best I know of for courses online, it has many features and it is very stable.

Please excuse me it took long to get back to you.

Thanks, Abie, I will check it out! Stable sounds wonderful right now!

I'd run with a testing site first to see how it functions and when I am happy I can apply to main.

Or you may ask site support to do you a staging website on a siterubix to test things out first before you apply to main.

https://my.wealthyaffiliate.com/websites/support

No worries! Not your issue🤣
I'm just happy for any suggestions👍

No worries AI.

Hope you get figured out sooner.

See more comments

I was wondering if anyone used "elementor" theme?

I was wondering if anyone used "elementor" theme?

asked in
Website Development & Programming

Good Day, my beloved WA family.

I was wondering if anyone used "Elementor" Theme?

I use Thrive Themes currently. I have courses built on my website that are my ma

Hi Al...I'm just reading the thread. I stayed away from it because I had heard it was difficult. But I'm learning a fair bit in the comments below. I hope it all works out for you!

Susan

Thanks Susan!

I'll figure it out eventually then post what I did👍

Keep thriving!

Al

I've thought about it, AL, but had heard that it can be difficult to use, among other things! I hope you get some good answers!

Jeff

Yeah, Jeff, I'm going to wait for the theme support and talk to them before I decide anything.

They're in Germany so I won't hear from them fire awhile.

I'll figure it out, I've had some good suggestions here👍

Thanks fur reaching out, I'll be commenting on your awesome day later on tonight.

Stay well my friend!

Al

You're very welcome, AL, and whenever you can, my friend, is fine!

Keep thriving!

Jeff

Hey Al,

Both of those you mentioned, they are NOT themes but rather pagebuilders.

Pagebuilders can devastate a site when developers desert them. One of my clients who came to me with his site... well, his site had a pagebuilder that the developer deserted once WordPress introduced their Block Editor.

Pagebuilders also add to the time it takes for a page to load, so I'm not surprised to learn that Thrive Themes pagebuilder broke your website.

Have you communicated with Thrive Themes to get their help in fixing your site? They used to be great at the support they offer.

Though after they walked away from properly supporting all of the theme they used to offer... and those that I had purchased from them, I no longer trust them.

Trish, thanks for your response,

It is what I use for my theme. Omni from Thrive Themes.
The Theme isn't the main issue, it's the course-builder plugin.

The courses work well, but about 50% of the time on updates, the code has a flaw in it and it crashes my site.

Support then deactivates the plugin so I get my site back, but no courses until Thrive support fixes the issue on their end.

Anyway, they always do fix the issue, but often it takes some time because of our time differences.

Ahhh... then if the issue is with the plugin, then THAT'S who you need to reach out to... their support, as I'm sure that would be the quickest way.

If it is NOT your pagebuilder that is the issue then changing to Elementor's pagebuilder won't resolve your issue either.

Hope this makes sense.

Creating a backup of your site BEFORE doing updates really can be a website saver. So... next time... right?

It does, but I don't think I can use another course building plug-in that is compatible without changing themes.

This is my issue. I need those courses, they are an essential part of my income!

Whose course builder plugin are you using, if you don't mind my asking you.

Thrive Theme's "Thrive Apprentice"

It's great when it is working!

Ooooh... so, you're using their Architect (pagebuilder) AND their plugin Apprentice. YIKES!

Soooo... how long did they say they would be before repairing their plugin so that your site training will be once again available?

They haven't responded yet. It normally takes 10 - 12 hours, probably because of time difference. They are in Germany. I'm in California.

So you can see why I want to change. I also use their theme, as well as architect and apprentice. The Theme is not a plugin, it's a theme, the only one I have.

Technically, you could use ANY theme when you are using a pagebuilder. And, who knows for certain, their theme MAY be causing you the issue you are experiencing.

I have only one website yet to remove their theme from. That site being my hobby site, I tend to neglect it and their theme has degraded terribly.

It doesn't surprise me, as they announced a few years ago that they would NOT be fixing their themes going forward, NOR supporting them. They've stuck to that promise, of that I can assure you.

Hopefully you can get this fixed. Though once fixed, and in the months to come, I would be giving serious consideration to leaving Thrive products all together, as their support for any of their products are not long lived.

I use Thrive Theme Builder on all 25 of my websites and have absolutely no issues. Which plugins cause the problem when they update?

Also, I believe Elementor is a website design tool, rather than a theme.

I have had this issue mostly with Thrive Apprentice. It is what my courses are built on. I have had it happen with Thrive Architect once, and Thrive Themes twice (I use Omni).

It's always the same issue, A piece of bad code installed in the update.

It's getting old.

I'm glad you have no issues, I have no idea why I do.

I still have a couple of sites with legacy themes (Rise and Luxe) but almost all now use Thrive Theme Builder. You are welcome to look at the sites listed on my profile to see how it looks.

I've started to use Apprentice and have had no issues yet, but it's early days.

I will check them out, Thanks, Phil!

Your sites look great, Phil, you're a master website builder.

I didn't however find any courses, but maybe I didn't look hard enough! 🤣

That's correct. I haven't published any yet. Also, only 7 of my sites are shown on my profile, as that's the most WA allows you to list. I do have sites where you can sign up to be notified of courses when they are published.

I'd have you check mine out, but apprentice is down right now.
I'll let you know!

I contacted thrive themes, perhaps there is something on my site that isn't compatible, if you're not having any issues.

Let me know how it goes, Al. I'd love to check out your site for you.

Will do, Phil, thanks!!

I use Elementor Pro.

However the sensible thing here is to reach out to Site support try find a solution or restore your website to a previous date without the update see if it can be fixed.

Thanks Abie!

Site support is always great.
I always get the issue fixed.

However, sometimes I don't catch it for a few hours.

It usually takes a half day to get help from my theme support as they are in Germany and I am in California. So I could be down a day. That isn't optimum for either selling courses or students taking them after they have paid good money to take them.

I saw that Elementor Pro offered course building. Have you had any issues with it crashing your site when the Theme or its plugins update?

Thanks Abie!

I know that ultimately this will benefit me and my website.

Keep thriving!

Al

I cannot guarantee that it will not crash. However Elementor Pro is a page builder as opposed to a theme.

Also Elementor has been known to slow down websites, however not the case with a premium caching plugin.

Have you considered LifterLMS WordPress plugin for courses, you may check it out here

https://wordpress.org/plugins/lifterlms/
https://lifterlms.com/

That's the best I know of for courses online, it has many features and it is very stable.

Please excuse me it took long to get back to you.

Thanks, Abie, I will check it out! Stable sounds wonderful right now!

I'd run with a testing site first to see how it functions and when I am happy I can apply to main.

Or you may ask site support to do you a staging website on a siterubix to test things out first before you apply to main.

https://my.wealthyaffiliate.com/websites/support

No worries! Not your issue🤣
I'm just happy for any suggestions👍

No worries AI.

Hope you get figured out sooner.

See more comments

Login
Create Your Free Wealthy Affiliate Account Today!
icon
4-Steps to Success Class
icon
One Profit Ready Website
icon
Market Research & Analysis Tools
icon
Millionaire Mentorship
icon
Core “Business Start Up” Training