Domain Email And My Frustration!

Last Update: October 15, 2017

Yes, that is me today!!! My frustration with my domain email is beyond extreme!

Why Am I Frustrated?

First off, it's the amount of spam that I get. Totally out of hand and I spend more time deleting spam than I do reading legitimate email.

Second, I have had to contact support because I am not getting my email. I have two websites. I wasn't getting email on either one. I tested it and didn't go through. They fixed the first one. No problems.

Now, the second website hasn't gotten any emails. Now, I know that isn't right because I usually get a lot of spam. So, contacted support today on this second site after trying to send email from my personal Gmail (and nothing going through), and got the response

So, they tested it and it says it went through. But, I didn't get it. Tried to send another from my Gmail and nothing.... Never heard from support again. Because theirs went through, that was good enough and they weren't willing to help further...REALLY?

Now, usually, I'm a very patient person and I have usually had a good response with site support. But, today, I am very frustrated!!!

What good is site domain email if it doesn't work or full of spam? Does anyone else feel my pain or is it just me?

Does anyone have a good alternative?

Join the Discussion
Write something…
Recent messages
PatsyC Premium
Hi Jean, I just sent you an email to see if you get it.

I went to your profile to get access through your website but it's not listed. Google+ was so I follwed you there ;)

I don't get why you have spam, and think there is a spam blocker there. I would have to go find it...actually I think you have to 'check' a box to avoid it.
Reply
JeanL Premium
Which one did you send it to? healthandhealingwithherbs or buildingnewpathways.
Reply
PatsyC Premium
The one from this post...buildingnewpathways
Reply
JeanL Premium
Nope, didn't get it. Will have to hit up support again tomorrow and hound them till they get it fixed. Thanks for trying, Patsy!!
Reply
PatsyC Premium
I wonder where the emails sent there are going to??

You are welcome, SiteSupport helped me with this once back in March.
Reply
JeanL Premium
Well, they aren't helping me today. Will try again tomorrow, but geeze, usually they are so good. But because they sent an email and it went through, they assumed they were done.
Reply
PatsyC Premium
Yes..done on their end.
Make sure you tell them a member testing it and it's not working.

Good luck!
Reply
JeanL Premium
Thanks! LOL
Reply
PatsyC Premium
Aha! got you laughing now ;)
Reply
JeanL Premium
And I appreciate it!!!
Reply
HarveyBrown Premium
It is bad when you know something is wrong but the specialists cannot find what it is. Sorry to hear about your frustrating day. Hopefully it will get better tomorrow.
Reply
JeanL Premium
Thanks, Harvey, I hope so too!
Reply
MarkusSA Premium
Hello Jean,

Just poking around today and saw you needed some help.
I've not had this problem with my sites so I'll start by asking the stupid question :)

I remember following this training to get set up, it worked for me. If I'm off base with this, feel free to pm me and if I can help I will.
I'll be working a few more hours so I'll keep an eye out for you.

Thanks,
Markus
Reply
MarkusSA Premium
Ok well keep hitting up support, I would think it's a problem on their end. Hope it gets worked out for you.

Markus
Reply
JeanL Premium
I will have a look at it. But if I'm not getting email to that box in the first place...
Reply
MarkusSA Premium
The way I remember it was:
when the site was created, it also created that email for you and that mailbox.

I remember the site email box for that email address where if you wanted to you could deal with it there.

But instead of doing that I was advised by someone (think it was Craig) here at WA, a better idea would be to just forward it to my gmail account then set it up there, so there wouldn't be any hassles down the road.
Reply
JeanL Premium
Just set up my first domain with this and works great. Now to try the one that isn't getting any email....stay tuned!
Reply
MarkusSA Premium
I'm tuned in :)
Reply
JeanL Premium
So, I tried the second one, and as usual can't even get the verification code because that email isn't receiving anything.
Reply
MarkusSA Premium
Thats odd, seems like it should work as well.
I don't know if this has anything to do with this but...

I've noticed that WA seems to do work behind the scenes especially on the week-end. Seems to me anyway, thats when I have my problems.

Last week-end I couldn't login to one of my sites and when they fixed it, the ssl was missing in the url after I logged in.
Reply
JeanL Premium
Ya, I'll let it rest for the day and try support again tomorrow. There is no reason why I'm not getting email in this account. I don't care if they sent one and it went through...no one else can.
Reply
MarkusSA Premium
K Jean, I'm sure they'll get it taken care of. If it persists I would contact Kyle or Carson, their always there to help.

But until then take that well deserved rest for the day. Let us know how it goes.

Talk soon,
Markus
Reply
JeanL Premium
Thanks for your help! Much appreciated!!!
Reply
Paul1916 Premium
Trying to login to site email is extremely difficult.
Raised tickets before to get in, sorted for a while then happens again.
I don't bother with site email anymore as a result as too much time is wasted not being able to login.
Reply
JeanL Premium
Well, and that too!! Very frustrating.
Reply
Edi67 Premium
you are not alone in this, I have set my spam filter onto certain time to delete or empty them automatically or I delete them all with one click.
Reply
JeanL Premium
I'm glad I'm not alone! Where are the spam filters? I have yet to find them. I do delete in bulk, but geeze.
Reply
Top