Weird Things Are Happening With My Amazon Links

Last Update: December 29, 2016

Hi everyone,

I have to share this case because I don't know how to go about and I would be grateful for any suggestions.

Over a week ago I added on both my sites a few plugins to improve the loading time. Shortly after I clicked on one of my Amazon links and instead on landing at the US store I am getting directed to the Japanese store. I checked my other website; same thing happens there. So I deleted the new installed plugins but the problem remains.

I checked on a friends computer, same problem. I get redirected to the wrong store (see image)

I got in touch with our support team but they can't find anything. The clicks are working perfectly fine on their end.

I really don't know what I can do about it? My sister in Germany checked the links and they worked fine as well.

If anybody knows what to do I would be grateful. It is so weird. Maybe it has to do with Amazon itself? Or maybe the links don't work in NZ? Even though they did before ...

Thanks in advance from Anke

Join the Discussion
Write something…
Recent messages
JeanBrickley Premium
Hmmm. Is there someplace your language could have been changed? I'd begin by checking my Amazon settings and then move on to check all settings. What plug ins did you try? Let us know how things work out. Jeannie
Reply
stephhill Premium
That is strange. I too have had problems with Amazon links not working right and I too have had problems with their tech support not responding to my concerns and I had to fix the problem on my own and go about it a different way.

Sometimes you need to get real creative about getting done what you need to and go through some back doors, but this is a strange problem for sure.

Keep us posted what you learn because I know many of us would be interested in knowing as well since so many of us are Amazon Associates.
Reply
AHohaia Premium
Hi Steph, I got in touch with our WA tech support. They couldn't find anything. The links worked with no problem at all.
I just send a request to Amazon and hopefully, they have an answer!
I wonder if the problem only exists for people who live in NZ? Chris from Canada tried the links and it worked.
I will keep you posted.
Thanks for your response!
Best, Anke
Reply
stephhill Premium
Thanks Anke. Good luck with Amazon's tech support. It could be something with folks from NZ, Not sure. Let us know.
Reply
drjec Premium
I just did a post on Amazon links, but for a different concern. Maybe you had the same problem I did, but the solution by Amazon is different because of different products.
Reply
AHohaia Premium
Hi Jim, can you post the link to your post? I will check it out.
Thanks Anke
Reply
cbarmby Premium
That's really strange, if you pm me a link to your site I'll have a look and see what it is doing on my end. I'm in Canada
Reply
AHohaia Premium
Thank you. I will pm you!
Reply
cbarmby Premium
It all seems to be working great on my end, it is bringing me to amazon.ca. Do you have an Amazon.ca affiliate account?
Reply
cbarmby Premium
Actually it was opening my Amazon app on my phone, when tested on the computer it was going to amazon.com
Reply
AHohaia Premium
No, I don't have an amazon.ca at the moment. I need to reapply. Most of my readers are from the States and the UK. Thanks for checking.
Reply
AHohaia Premium
At least it didn't take you to the Japanese Amazon store! That is good to know.
Reply
Top