Can't Crack it!

Last Update: Feb 28, 2020

2
490 followers

Ok, so feel like I'm doing something very wrong. To be fair the new site is only 2 months old and I'm really struggling for time. I've got 10 posts on there, none of them are indexed. The site is apparently indexed and I've submitted site-maps.

I requested for individual URLs to be indexed via the console a few days ago, nothing yet. So basically I had one organic visitor in two months, which is shockingly bad.

I'm pretty tech savvy but I feel like I'm missing something huge. I'm re-doing training and will be plugging away again this weekend but to be honest I don't see where the hope is going to come from! Call me #frustrated!

Login
Create Your Free Wealthy Affiliate Account Today!
icon
4-Steps to Success Class
icon
One Profit Ready Website
icon
Market Research & Analysis Tools
icon
Millionaire Mentorship
icon
Core “Business Start Up” Training

Recent Comments

2

Hi,
Patience my friend google does take a bit of time to index. Do not give up it is still early give it time and keep writing the contents. I am glad to hear you have gone back to training that is a wise move.I wish you all the best and that you will feel better soon once google start indexing your articles.
You are not alone the community is here for you ask questions on the question platform.
All the best !

Thanks so much. Good to have the support :)

See more comments

Login
Create Your Free Wealthy Affiliate Account Today!
icon
4-Steps to Success Class
icon
One Profit Ready Website
icon
Market Research & Analysis Tools
icon
Millionaire Mentorship
icon
Core “Business Start Up” Training