Google Console Is Doing My Head In!

Last Update: June 14, 2019

Hi Folks,

Just thought I would let off some steam by posting a quick blog...

ARGGHHHHHH !

Google console is doing my head in literally it is slowing down my work as I am trying to figger out what needs sorting and what doesn't...

I followed the training on setting it up and everything was going well until about a month ago.

It's so frustrating and I am sure my site is being affected as in May I had over 10,000 page views finally thought YEAH we are cracking this ... today I am getting just under 10 page views a day through Google search.

It is driving me crazy as with over 60 posts only 19 say okay on mobile. but they are all okay.

I am torn!

Do I spend even more time trying to go through everything ( I have spent far too long as it is)

Or do I just crack on with more content that seems pointless if its not going to even rank.

I am not going to let it beat me I have spent the last 8 months building this business.

Okay rant over everyone back to work LOL

Join the Discussion
Write something…
Recent messages
ewolfanger22 Premium
I can only say LOL because if you don’t laugh you’ll cry. If I were losing that much traffic Ijusr might be panicking. Good luck with this McBride.
Reply
mcb247 Premium
I think I am back on top of Google so let's see what happens over the next few weeks
Reply
kevin928 Premium
Interesting to see the answers Martin, keep us in the loop with how you get on. My new site isn't ranking at all but only 6 weeks old with 20 posts but I had hoped for at least some impressions.

I realise that I have not be shortening the permalinks which may be causing me a problem although I do have some good posts on my niche site which are ranking page 1 or 2 with long URL's.

Dont know whether I shoud try and change them or shorten them as I have had different advice

Be interesting to see if resubmitting your site map will make a difference. Fingers crossed it does.

Have a good weekend

Kevin
Reply
mcb247 Premium
Thanks Kevin let's hope all sorts itself out. I don't think the Google update has helped either
Reply
kevin928 Premium
Lets hope so Martin
Reply
hummingbyrd Premium
I like Linda's solution, I hope it works. I wonder if it is caused by the google bots some people have mentioned.
Jay
Reply
mcb247 Premium
Thanks Jay
Reply
Linda103 Premium
I had problems with Google console, not accepting posts, then deciding posts already indexed weren't there etc.
I deleted that site from google console, then added it again, added sitemap and then the post URLs.
Seems fine at the minute.
Reply
mcb247 Premium
Thanks Linda something I can look at if things don't change
Reply
lesabre Premium
Lots of great comments. I hope you decide to crack on with more content. I am having the same problem and it is totally frustrating. I thank you for your question. I wish I could help.
All the best,
Michael
Reply
mcb247 Premium
Cracking on with content tomorrow Michael
Reply
AnaB7 Premium
Hello,

Are some of your posts not indexed in Google?

But they are showing in your sitemap in all in one seo plugin?

If that is the case you need to delete your sitemap on search console and resubmit your site map on google search console.

It will fix the indexing part.

I can send you screenshots of how I fixed mine. I was having the same issue. Unfortunately, I won’t be home until late afternoon to send you screenshots of how to delete the old sitemap in search console.

There seems to be an issue between all in one seo and search console not recognizing the automatic setting to crawl to index your posts even if they show in the sitemap in your plug in.

I would go into search console and my post would not be there even if they were submitted.

The problem sitemap. I submitted twice to fix the same issue.

It took me a while to figure how to delete the sitemap in google.

I didn’t have to make any changes to my all in one seo.

If you send an email to site support they can also help you.

Best,

Ana
Reply
mcb247 Premium
Thanks, Ana,

I have recreated my site map and resubmitted to Google and Bing. I must admit I didn't delete the old one.

I am going through some other issues at the moment where the alt tags are missing I think these disappeared when my theme had an update as I always add them in.

I think I am nearer there now taken all day to sort.
Reply
AnaB7 Premium
Glad to hear you are figuring it out. Yes, it takes a long time to sort out.

I hope all gets fixed.

Best,

Ana
Reply
davehayes Premium
Personally I would crack on and post content, but I would make sure all Search engines were covered and not just Google

I also use non SEO as well
Reply
mcb247 Premium
Thanks Dave, Setting aside today to get everything sorted on the SEO front then cracking on with a blog post.

Indeed doing YT FB and Twitter along with Quora too.
Reply
davehayes Premium
Well done I am doing YT only
Reply
mcb247 Premium
I think that is the best option as you can use the video on FB IGTV and twitter too. And of course, embed it to your blog.

I am doing one new video every week now. and two new blogs.
Reply
davehayes Premium
Cool beans and I am doing similar
Reply
mcb247 Premium
Great Minds LOL
Reply
davehayes Premium
Absolutely
Reply
feigner Premium
this is the time when you have to dig deep - do you believe it can work?...yeah...then it can.
as you say letting off steam.
i was suprised when you posted your figures a while ago, but pleased for you.
then sad when they dropped dramatically, but not unsuprised.
it is a tough niche and persistance will pay off.
i would go through the figures to see what was working, which queries were bring in the visitors. make sure they were real and not bots.
were they converting or just visiting?
and create more content around those keywords, but make sure they were real visitors.
as you say the kettle is off the boil for the time being - good luck Martin
phil
Reply
mcb247 Premium
Thanks, Phil,

The kettle is on!

I am going back to basics and resetting up all in one SEO plugin and going through everything with a fine tooth comb.

As regards to the traffic, it was all genuine I was getting 7-8 signs up a day into WA. The company I reviewed at the time has changed its name so most of the traffic has disappeared now.

I have created a new post with both keywords in and started to get some traffic there but only a few clicks.

I think my problem is Google not seeing my site even though everything is set up hence why I have decided to go through everything.

Thanks for your advice much appreciated

:)
Reply
feigner Premium
i have just answered this for some one else whose traffic has diasppeared.
in google analytics you can get googe to send test traffic to a page.
but if you are getting hits then google still sees your site.
what about your rankings - have they followed the traffic or are they stable?
you can check each page to see if it is still indexed - or systematically go through and update the posts that were performing.
it is frustrating, but aprt of relying on google for traffic.
i have just looked at the traffic on my mmo site and that has taken a massive dive over the last few days - but as google has just updated its algorithm - i wouldn't panic.
things take time on the internet backend, so keep blogging and see how things pan out.
there is always paid traffic.
Reply
mcb247 Premium
Hi Phil,

Rankings fairly stable well the view I have LOL.

I will do the test traffic as I go through all the posts and make sure all SEO stuff sorted etc.

Nor even looked at the paid traffic option yet as wanted get some organic traffic first to know It was working especially as teaching others to do the same.

Thanks for the heads up on GA test button. I am learning all the time cheers :)
Reply