You Tube Video Slowing Down Site

Last Update: June 04, 2019

I just added a You Tube video to my homepage and it's slowing down my site. I didn't think this would be an issue since the video is hosted on You Tube.

Has anyone else run into this problem? What do I do about it?

Thanks so much for your thoughts!

Holly

Join the Discussion
Write something…
Recent messages
bpais1 Premium
Have I got a fix for you, Holly!

Check out: Jim
Reply
Hollshope Premium
Awesome. Thank you!
Reply
Fleeky Premium Plus
Sounds weird, rather unusual
Better ask site suport
Reply
Hollshope Premium
Good idea!
Reply
GlenPalo Premium
I ran into the same problem. So I just made a clickable image of the YT video and put that on my post instead of embedding the video.
Reply
Hollshope Premium
Now why didn’t I think of that? I’ll try that.
Reply
Zarina Premium
Honestly, I've had LEEENGTHY articles with at least 5 embedded videos and the site speed was normal, pretty much the same as the posts with no videos at all.

Are you sure it's the video that's causing the problem, Holly?
Reply
Hollshope Premium
My site speed was 99 for both desktop and mobile until I added the video. So frustrating!
Reply
Nadia27 Premium
The best thing will be to link to a YouTube video, put a picture of the video with a play button. And put a link of your video. But not to put it directly, because it slows everything.
Reply
Zarina Premium
Actually, I'm pretty sure I heard people say that embedding a video carries less weight than putting a pic. Don't take my word for it tho.
Reply
Hollshope Premium
That’s a great idea. I should have done that to begin with. Thanks!
Reply
Hollshope Premium
That’s what I thought too. I embed a video in every post I write and have never had a problem. Thanks for taking the time to comment.
Reply
Top