Where are you, Google!?!?!?!

Last Update: April 30, 2021

Just looking for some community support here...I have 14 posts on my site now that has been active for 3 weeks, I am at 100% in site health for everything except Google Indexing and site trust....I have set up the Google Seach Console and Google Analytics...and still no indexing.

So I'm wondering if this can be a normal thing? Do I just keep posting content until they index it? Any other suggestions?

Thanks all!

Join the Discussion
Write something…
Recent messages
JeffreyBrown Premium
Sometimes Google is slower out this, Kory!

Jeff
Reply
Arnkor Premium
Thanks! So just keep posting?
Reply
JeffreyBrown Premium
Yes, indeed, Kory!

Jeff
Reply
Arnkor Premium
Google found me!!
Reply
JeffreyBrown Premium
Ha ha! Well done, Kory!

Jeff
Reply
Dana57 Premium
Under your Google Search Console, you can submit your pages you want Indexed. So go to search.google.com/search-console and that should start taking you to your Search Console. From there you will see URL inspection....click that ...enter your https://yoursitename.com and start from there. It will retrieve the page and tell you if it is indexed. If it is not indexed, click "TEST LIVE URL"....It will tell you URL is available to Google. to the left you will see "REQUEST INDEXING"...click that. Give it about 24 hours and that page will be indexed.
Reply
Dana57 Premium
Sorry not left but RIGHT...you will see TEST LIVE URL. I am blonde and tend to be backwards sometimes LOL
Reply
Arnkor Premium
Thank you!
Reply
Arnkor Premium
Google found me! Thanks again!
Reply
Top