Video by nathaniell
Added Feb 19, 2015

Author nathaniell
2010
4
Premium
Ambassador
Rank 4
Unfollow

Here's a video with some troubleshooting tips if your'e getting a 404 on a specific page of your website. This is a common thing I see when someone tries to change a permalink, but doesn't know what it actually is, or how to explain what they did. Hopefully this helps.

Also, just to prevent anyone issues related to this video:

1. If you are not getting a 404 or don't have any issues with your site right now, DO NOT change your permalinks. Just enjoy the learning from this video :)

2. DO NOT go in and change a bunch of permalinks to try to optimize for SEO! If you realize you made some kind of mistake, just move forward with posting and keep that in mind for the future.

3. Some themes will show "Custom Structure" and /%postname%/, which is basically the same thing as /sample-post/. If your URL matches your blog post title, then you are good to go.

Join the Discussion
Write something…
Recent messages
jecf1979 Premium
Thanks for sharing this video.
I have a doubt.
After the feedback from another user of WA, I did some changes on the title on a few posts, I was checking my post links on the website and everything is ok links works.
But, when I check on the website manager on WA platform, the title of one post looks different than on my website. That is ok? That specific post is already index on Google.
What do you do in this case?
Reply
FKelso Premium
You'd probably better make the post title the same in both places. I just changed the title of a post, and when I tried to add it to the social media, it said there was an error; the post could not be found. Then, when I went back and looked, I discovered the permalink to the post came from the old title, so it did not agree with the new one any more. If you change your title, make sure your URLs for the post and you permalink all agree with your new title.
Reply
CherylK Premium
Thanks, Nathaniell. That helps with the 404 errors. I've used the free Broken Link Checker but it doesn't help me find exactly where the errors are located. I thought there was a way to see the exact thread in the source code but it's not working for me. Any idea why that is?
Reply
KristylaureL Premium
Awesome Training Tutorial Nathan. Much needed and appreciated!
Reply
AnastaciaN Premium
I moved my website and had the 404 error! thanks for the tutorial I only needed to change permalink settings and that solved it.
Reply
amyr2017 Premium
Great video, Nathaniell -- I didn't even know this existed...! Very helpful but I'm happy to report that I have no issues...!
Reply
LacedUp Premium
Hi, great video. Thank you. Have this issue on 2 posts. My question is if I republish do I loose all my comments? Is there a way to transfer them?

Thanks
Reply
benandnili Premium
Republish (as in to update) - no. Or move or copy the article to another site (or so) - yes. I hope that helps.
Reply
johncruz Premium
Lace! How in the world have you been?! Did you get this problem resolved?
Reply
LacedUp Premium
Thanks mate
Reply
LacedUp Premium
Hi John, I'm good thanks. You? Turns out the problem is with email subscribers permalinks (I've not messed with those at all, they remain the same as the plugin installed them) so no, not sorted but I'm not worrying about it either
Reply
My-Mate-Bert Premium
Hiya, Natheniel,

Just as well you mentioned about NOT changing things for the sake of it.

I was about to....
Reply
viyee Premium
Hi Nathaniel, Great video, Thank you very much.
Reply
E-Udoh Premium
In your video, you focused on fixing permank for the blog posts. Can the same method be applied to fix pages permalink?


Thank you!
Reply
Labman Premium
Yes
Reply
E-Udoh Premium
Awesome and Thank you!
Reply
DSonic Premium
Thanks ,
It's getting clearer now.
Reply
Rich908 Premium
Helpful thanks
Reply
SplitHead Premium
Thanks Nathaniell this helped a lot!
Reply
chrismason Premium
This has helped me. Thanks.
Reply
MrAlexey Premium
Wow Nathaniel - Thank you very much :)
It was helpful!
Reply
mbouteiller Premium
Hi Nathaniell, thank you for your video! I just watched it...not quite sure I understand. This is my error message...

Error 404 - Page not found
Sorry, the page you are looking for has either been moved or removed from the website.

Yesterday, I installed Pretty Link and was going through the procedure of making short affiliate links. I was working on my Wealthy Affiliate Review post and my short affiliate links I created are working fine and then I did the same for an internal link (which goes to a page) I have in this review post. I ended up with an error when I clicked the Create button in Pretty Link.

I did a no no and changed the wording in the permalink in Pretty Link...arrrggg

When I went back to look at my site in view, the Wealthy Affiliate Review post comes up but when I click in the internal link, I get the message as shown above ....

I can bring up my page (the one I wanted the review to internally link to) ...

What am I doing wrong?
Reply
EdwardLarry Premium
Thanks Nathaniell your training was great, You can have a look at my URL edwardlarry.com It doesn't seem to have a 404s problem.
Reply
nathaniell Premium
I know that you do not have 404 errors. I only wanted you to watch the video to see the end so you could remove the date from your post.

Anyway, I see from the URL here: http://edwardlarry.com/how-to-have-beautiful-natural-skin-8/ that there are no dates on your post URL structure anymore, so you seem to have fixed it!
Reply
VonnieOh Premium
Hi, I am using "Custom Structure" for my Common Settings under Permalink Settings. Can I still change it to "Post Name" if I have already published some posts? Will it affect my site SEO?
Reply
electrobot Premium
Hi VonnieOh. Yes, you can still change it to "Post Name". However, I don't know how this will affect your site's SEO.
Reply
verna8767 Premium
Nathaniell, thanks for this training. I had 2 posts that I got the "Oops! That page can't be found". Your training explained exactly what I had to do to fix it. Now both my posts are back where they belong!! Thanks for the training. Verna
Reply
DSuter Premium
Sorry for the question I just read further and found my error but that leaves me wondering why I'm getting a 404
Reply
nathaniell Premium
Maybe you deleted a page at some point? 1 404 is not a big deal, and will not affect your site's SEO or rank.
Reply
nathaniell Premium
It's also possible that another website linked to a page that doesn't exist, which means you don't have control over that 404, and can just mark it as fixed or ignore it.
Reply
DSuter Premium
Thanks! Upon further investigation it seems it is a photo gallery page? To my knowledge I have not created one lol and not sure what the heck they are talking about.
Reply
DSuter Premium
I did have a site Rubix page which I moved to my domain maybe that's it?
Reply
nathaniell Premium
That might be part of the issue since it recently moved.
Reply
SupportWorx Premium
I thought I heard that broken links WOULD actually hurt your SEO... that's good news if it doesn't. -Alexx
Reply
DSuter Premium
Webmaster has given me 1 404 error after watching the above video I went into my permalink settings and found that, custom structure was checked, should I change that to post name as the video suggests or should I leave it. I have never changed this setting since starting here at WA.
Reply
Sheri13 Premium
Thank you so much! You saved me from going crazy.
Reply
jphe Premium
Thank you for your help,
I am not getting a 404 page, I will go and look at the permalinks and let you know what happens,
What is a PM? my computer skills are not very advanced.
Reply
alleo Premium
A PM is a Private Message
Reply
CCunningham Premium
I reviewed this training again, I have trouble with permalink.
Reply
nathaniell Premium
Send me a PM and I can take a look inside your site if you want.
Reply
jphe Premium
Yes I would like that, can you send me another E Mail
Reply
CCunningham Premium
I have already had the /%postname%?. That was a real headache.
Reply
Inspiration1 Premium
Thanks nathaniell for giving new knowledge.
Reply
Kenester Premium
Thanks!
Reply
MozMary Premium
my default is custom structure - is that ok?
Reply
nathaniell Premium
yes, I'm sure it says something like /%postname%/ correct? I've seen that with some themes as well. I added an additional note to the text portion.
Reply
MozMary Premium
Yes, that's it, thanks for clarifying!
Reply
JAZZmom41 Premium
Thank-you Nathaniell
Reply
justbobw Premium
Thanks. Not sure what a 404 is.
Reply
nathaniell Premium
404 just means "page not found", ie your website cannot find what you are looking for.
Reply
justbobw Premium
Thanks
Reply
AntoniOom Premium
Hi Nathaniel. Good te know! Thanks for informing. Regards Antonius
Reply
JewelCarol Premium
Thank you very much for yr kind training, Nathaniell!! :)
Reply
EFors Premium
Thank you for the training always welcome and bookmarked. :)))
Reply
Christabelle Premium
I have certainly seen enough questions on this so thank you for the training!
Reply
siamjerry Premium
Thanks Nathaniel, I saw that my permalink was set to custom structure and I have never had any problems. I have saved it anyway, as you suggested. No need to change then?
Reply
Judy-B Premium
Not having this problem, but will bookmark so I'll have it if I do. Thanks :)
Reply
Tinnakon Premium
Hi I will have this in my mind if I have this problem.
Reply
Loes Premium
Bookmarked it:)
Reply
silah77 Premium
Thank you for this training Nathaniell.
Reply
kennnyb Premium
Thank you
Ken
Reply
gadifi Premium
thanks for the training as always
Willie
Reply
mrpeter Premium
Timely as always Nathaniell! Thanks.
Reply
Top