Author MarionBlack
2014
2
86
Premium
Ambassador
Rank 86
Unfollow

In this video you’re going to learn how to submit your sitemap to Google Search Console.

Before you do that you’ll need to set it up using your SEO plugin.

Sitemap: Using All In One SEO Plugin

Sitemap: Using Yoast SEO Plugin

If you're using All In One then your sitemap URL will be domain.com/sitemap.xml and if you're using Yoast then your sitemap URL will domain.com/sitemap_index.xml.


More Training by Marion Black - Sorted

As always, I’m here to help you.

Please share the love, click 'Like This' (if you do). Ask a question, share something or leave a comment.

Join the Discussion
Write something…
Recent messages
kevin928 Premium
Hi Marion, thank you for this, as always a big help. I have just been using the new console so have gone to the old version and followed this as someone said I should request indexing by fetch to google after posting and article so have followed this training. My seo all in one was set up and my sitemap added to google search console so I assume it would do this anyway but i guess this speeds up the process? Im just trying to set everything up correctly and find it frustrating not knowing if I am doing it right. I have published 9 articles and 7 are indexed by google but when I look at the seach console (old version) it tells me I have 39 submitted web pages and only 14 are indexed and 58 images of which non are indexed. Is there anything else I should be doing that I am missing?

Thanks you so much for your help. Been a few hours now looking at the training for this and feeling a bit lost, particularly as I'm sure its all pretty simple! Off to write another article and forget about it for a while!

Thanks so much in advance for your help
Reply
Pernilla Premium
What would I do without you Marion!
This video was extremely helpful for me.
It worked out very well, whith your help.
Google found my website!!

There is one issue. I did Fetch Google.
Google could not fetch all ressources (images).
These are the logos of my Affiliatepartners with my link code to those Affiliates.
It says these images are blocked. Is this something I must react upon?

Pernilla
Reply
MarionBlack Premium
Perhaps the images are blocked because they are not on your own website.
Reply
Pernilla Premium
These images are within the code I got from the affiliates. Then I suppose, that the images are retireved via them to my website. It's complicated to understand how it all works.

I can't change this, otherwise I won't get compensated for any sales made.
Or what do you mean, Marion?
Reply
MarionBlack Premium
This is not something you can change, so just ignore it.
Reply
Kemdi12 Premium
Good day Marion
I have enabled my All in one SEO and I can view my XML sitemap
However, I get lost when you have to activate it using google search console?
I don't know where to go in order to choose the preferred version of my website or how to get to crawl that will take me to sitemaps
If possible I will need help navigating my way on google search console
Thanks
Reply
Nadja3 Premium
The following training can be very useful:
Reply
LouisaB Premium
Thanks Nadja, for the link.

very helpful!
Reply
BrianCh Premium
Hi Marion, I hope you are able to help me again. I went on to Google Analytics today and saw that there was no sitemap which I had submitted last week. On the right there used to be blue and red bars but they weren't there today. It's only Crawl Errors and Search Analytics. No Sitemaps.

I also saw that there were errors which I checked and it said that the sitemap does not contain any URLs. Please validate and resubmit.

I went to WordPress to All In One SEO and when I click on "view your sitemap here" I get a message that says, "This XML file does not appear to have any style information associated with it."

Please can you let me know if you have ever encountered this and if you can advise.

Thank you,

Brian
Reply
MarionBlack Premium
Do you have more than one plugin trying to generate your sitemap?

If you have Google XML Sitemaps and All in One SEO and Yoast SEO (or any combination) then they will clash with each other. Choose one of these but not two or three.
Reply
BrianCh Premium
Hi Marion, thank you for getting back to me. I only have the All In One SEO XML Sitemap installed and activated. It was all in order last week but I had an update for the theme and not sure if this is what affected it?

It's just strange though that Google Analytics isn't able to pick up a sitemap. Google does say that they are in the process of validating the index coverage issues. It might be worth mentioning to you that I removed 2 images from the Library that were duplicates and not associated with any of the pages on the site. These are the 2 issues that Google is having a problem with.

Thanks for your help.

Brian
Reply
MarionBlack Premium
Contact Site Support. They may be able to figure out why your sitemap is not working properly.
Reply
BrianCh Premium
Thanks, Marion. I was just thinking that I should probably contact them as well.

All the best,

Brian
Reply
BrianCh Premium
Hi Marion, just a report back. Contacted SiteSupport and they had it sorted out for me in minutes. They are the gang!! I published a post earlier to sing their praises.

Thanks always for your help.

Brian
Reply
monamassoud Premium
Hi Marion. Thank you so much for the training. I wouldn't have done it this way on my own.

I've done all the steps correctly but when I reached the last step after rendering, I got this message:
"Googlebot couldn't get all resources for this page". I got blocked script, blocked images, and blocked resources mainly from embedded tweets or an external link. Anything I can do to fix them? Or should I worry about it?

Many thanks,
Mona
Reply
MarionBlack Premium
I think that Google doesn't need to access those blocked resources so I wouldn't worry about it.
Reply
monamassoud Premium
Great. Thanks :)
Reply
NemiraB Premium
Thank you, Marion, for the precise training. However, when I follow your instruction, I do not see how Google boots perceive my website. It was explained on the 2:50 in your video. I use All in One plugin.
When I checked history, it seems that robots crawled all links. I confused because some details in the process of submitting sitemap do not fit with your training. Did I skip something? Sincerely, Nemira.
Reply
MarionBlack Premium
You'll want to use thje httpS version of your website when you 'fetch' to avoid the redirect.
Reply
NemiraB Premium
Thank you for the answer, Marion, could you give me a link where I could dig to learn more?
Reply
MarionBlack Premium
Perhaps watching the video again will make things a bit clearer.
Reply
NemiraB Premium
Nice, thank you very much:)
Reply
Heatlat Premium
Can anyone tell me why when I "fetch and render" my sitemap, it shows I have 277 URL's but only 146 have been indexed...I have been stuck at 146 forever! I fetch and render after each post is published...I don't seem to be getting any more indexing on my other URL's...any advice?
Plus I have never showed a Completed, only a Partial has ever shown when I request indexing....is something wrong?
Reply
SuzetteH Premium
I recently had that problem as well. I found out that I was missing a forward slash. Be sure that the Path has a forward slash / before the slug and well as after /.
Reply
Heatlat Premium
Do you mean in the area where you add the sitemap.xml?

Please see my screen shot, this is all I have ever added to the box....am I missing something?
Reply
SuzetteH Premium
Partial: Google got a response from your site and fetched the URL, but could not reach all resources referenced by the page because they were blocked by robots.txt files. If this is a fetch only, do a fetch and render. Examine the rendered page to see if any significant resources were blocked that could prevent Google from properly analyzing the meaning of the page. If significant resources were blocked, unblock the resources on robots.txt files that you own. For resources blocked by robots.txt files that you don't own, reach out to the resource site owners and ask them to unblock those resources to Googlebot. See the list of resource fetch error descriptions.


Copied the above information from https://support.google.com/webmasters/answer/6066468

Hopefully this will help my dear. What I suggested was the fix I did for redirect error messages when I ran a fetch.
Reply
Heatlat Premium
Ok, so just put another / at the end after the sitemap.xml after my website and did another Fetch and Render...now it shows complete!! Is that it then? Did it fix??
Reply
SuzetteH Premium
Who are the banners from. That are causing the problem?
Reply
Heatlat Premium
Sorry I deleted that comment, just a couple of my affiliates...but I did the other suggestion and got a complete....maybe that worked??
Reply
SuzetteH Premium
Awesome, Awesome, Awesome Heather. That is the best news I have heard all day.

Wait a day or two and do a fetch again and see what happens. Be sure to let me know.
Reply
MarionBlack Premium
I see Suzette has helped you with this Heather. Thank you Suzette.
Reply
MarionBlack Premium
Thanks for stepping in Suzette, I was asleep :)
Reply
SuzetteH Premium
No problem Marion, It was pleasure working with Heather. It is such a great feeling to know that I could help and it worked!!

It always helps having the best teachers and mentors such as yourself Marion :)
Reply
AdeRobinson Premium
I've just discovered that a plugin that I'm using, Sumo, which I use for list building is causing the status in Fetch as Google to be Partial. When I click in the row to be taken to how google and visitors see my site, I see this error at the bottom:

URL: https://sumo.com/api/load/ | TYPE: AJAX | Reason: Error

At the top, I see "Partial" next to the date of the results.

When I remove the plugin, it is changed from "Partial" to "Complete", and there are no errors.

Would this error impact my site indexing? And if so, how may I configure Sumo or my list-builder or any other plugin to not have this error?

Thanks
Reply
@RICH. Premium
Ade, also be aware, that unless you're grandfathered in to the free version, once you exceed 1000 visits a month or so, SumoMe will charge you $360 + taxes per annum for the next 4000 monthly visits.

http://www.sumome.com/pricing

If you don't pay up, it stops working.

Also, Noah, the owner, admitted in a webinar that I attended that free users go to the end of their server queue for requests, which can seriously impact your load times on occasion, and speed is a ranking metric.
Reply
AdeRobinson Premium
Thank you, Richard. I feel that I would have to use an alternative to sumo.
Do you have any suggestions?
I primarily like the pop bar at the top of the page (non-invasive), and a contact form at the bottom or side.
Reply
MarionBlack Premium
There are many other plugins you could use apart from Sumo. Check out Contact Form 7 which is very popular.
Reply
AdeRobinson Premium
Thank you, Marion!
Reply
VandanaR1 Premium
this worked, but down on the bottom there are links that say :

Googlebot couldn't get all resources for this page.

Here's a list:
url: https://mproxy.banner.linksynergy.com/fs/banners/41999/41999_39.jpg
type: image
reason: blocked
severity: high

anyone know what i did wrong here and how to fix? thanks in advance
Reply
MarionBlack Premium
I followed the link and it leads to a banner (see image). Go back to the company you got the link from and they should be able to help.
Reply
VandanaR1 Premium
Thanks for your quick response. It didn't give me any info on the company page, but I just put a new banner up. Could some banners just have bugs in them and we should just get new ones? I also noticed I put this in a widget under "visual" vs "text" maybe that did something. When it says "blocked" does that mean this post won't be indexed? sorry for all the questions!
Reply
MarionBlack Premium
Code always goes in Text. So use the Text tabs in your post editor and the text widgets instead of the Visual tabs.

It would be the image that's blocked not the whole post.
Reply
VandanaR1 Premium
ah! thanks for helping me with that! :D
Reply
LindaKwas Premium
Thanks for this...I am somehow miraculously finding everything I needed today...wow..not many days like that. Submitting a site map is on my list of things to do, and this is the second time today I have come across something I needed without having to look for it!
Reply
SuzetteH Premium
I have followed all the instructions that you gave me. AIO is deactivated, Google xml is deactivated. When I went to sitemaps it is showing that I have a sitemap /sitemap.xml which I know is the Google xml sitemap.

Do I go ahead and delete this sitemap before submitting the Yoast sitemap?
Reply
MarionBlack Premium
I don't know :(

Type your domain.com/sitemap_index.xml into your browser and see what comes up.
Reply
SuzetteH Premium
I have included a screen shot of the results. I also read on the Yoast website, after posting this question, it instructs you to remove outdated or invalid sitemaps like sitemap.xml
Reply
MarionBlack Premium
YAY! Now you're teaching me :)

Delete the All In One SEO plugin and see if the sitemap.xml file disappears. If the plugin cleans up after itself then the file will be gone. Otherwise you may have to ask Site Support to remove it for you or do it yourself using FTP.
Reply
SuzetteH Premium
LOL, I think I will rely on Site Support. I don't really think I am ready to mess with the FTP (I don't even know what that is :) )
Reply
PhilipC1 Premium
I can't submit a sitemap because I am still stuck in verifying ownership of my website. I can't upload a html to my homepage or work out how to do any of the other options to verify options.

I can't believe how hard this is and I have been at it since joining WA!

Any help would be appreciated!

Thank you.
Reply
MarionBlack Premium
The easiest way to verify your website with Google is via your SEO plugin Any time you get stuck Philip, just ask a question and someone will be here to help you.
Reply
Top