Are you getting a javascript error when leaving a comment?

Last Update: August 17, 2016

I have been seeing a javascript error when I go to leave comments on peoples websites here at Wealthy Affiliate.

What I have found is that the blogs that I am trying to comment on are using a spam plugin. I had the same problem a few months back and had to disable my WP-spamshield plugin.

We actually don't need any sort of spam plugin if our sites are hosted here a Wealthy Affiliate because of the amazing site security we have here. So if you are using this plug in, you may want to disable it.

I also recommend removing any captcha plugins because it isn't needed. But also the captchas often don't work and this in itself could be preventing folks from getting more comments on their site.

Have a great day!

~Wendy


Join the Discussion
Write something…
Recent messages
jvranjes Premium
Yes I had this error reported today, did not understand the reason.
Reply
wendyk Premium
Well, hopefully, this will help.
Reply
maxser67 Premium
Thank's Wendy!

You can read more about that here:
Reply
wendyk Premium
Thank you so much Max. It should be very helpful for folks.
Reply
fiftarina Premium
Thank you Wendy. I also had this problem and I wonder why. So it's wp-spam shield plugin. I have deactivated it now. Thanks once again.
Reply
wendyk Premium
You are welcome. Hopefully now you will get comments and folks won't get the error. :)
Reply
HarveyBrown Premium
Thanks Wendy, this happened to me the other day when I tried to leave a comment on someone's site.
Reply
wendyk Premium
Yeah, when it happens I just PM them and let the know. Thank goodness it is an easy fix.
Reply
CathyS Premium
No issues on this end, Wendy.
Reply
wendyk Premium
Great Cathy!
Reply
Top