How can I get ride of the security alert: Certificate not valid?

Join the Discussion
Write something…
Recent messages
nathaniell Premium
If it says "Connection Not Private", there are a couple ways to troubleshoot this.

First, make sure you are typing https:// instead of http. You might be seeing a "cached" version of the old URL.

Also, don't forget to clear your browser cache after each change to make sure you view the current changes, not the cached version. Make sure you're using the Chrome or Firefox browser (Chrome is better) as well.

Next, go to your website manager area, click "Details", then turn SiteSSL ON. If it's already on, turn it OFF then ON again. See if turning "Extreme" ON/OFF changes anything as well.

After that, you can contact SiteSupport and see if they can fix the problem. If it's related to the hosting and SSL certificate, they can fix it: https://my.wealthyaffiliate.com/websites/support

If they say that they are good on their end, you can view this training as well to find individual elements which could be breaking your SSL: Let me know if those solve it!
Reply
gwendell1 Premium
Ok, I will try everything you suggested. Hope this works for me. I would hate to lose my website. I have worked so hard on it. Will let you know if this works.
Thanks, Gwendell
Reply
nathaniell Premium
You won't lose your website. Everything is fixable!
Reply
gwendell1 Premium
Site support was very helpful and fixed it in less than 10 minutes. Wealthy Affiliate is definitely here for me and I'm happy to be a part of this community!
Thank You
Reply
nathaniell Premium
Awesome. Glad to hear it!
Reply
lesabre Premium
Hi Cathy, there is a plugin you can use:

Really Simple SSL
Premium Support | Docs | Settings | Deactivate (revert to http)
Lightweight plugin without any setup to make your site SSL proof

Version 3.3.4 | By Really Simple Plugins | View details

I see Keisha has given you an alternative way also.

Best wishes,
Michael
Reply
keishalina9 Premium
hey hi Cathy ... good question and all questions are good ones here ...

presumably, your question relates to a website that you have hosted here at Wealthy Affiliate? .... in that case, the SSL already comes with your WA Premium membership for your sites.....

if yes, simply go to Site Manager >> Details (it's the far lower right corner in a box) -- click on Details and then you'll be taken to a new page where a lot of important functions reside ... the free SSL (HTTPS) is just a scroll downward and simply click to ON ..., re-boot / refresh and it should all be good to go ...

hope it works out ok for you ... please do advise us once you've got it done back here in the reply box .... all the best ... :)
Reply
JeffreyBrown Premium
You've got some good answers below, Cathy!

Jeff
Reply
AbieAJ Premium
You will want to check the date and time your computer is set to. Let us know if that resolve it. Also check to see if your sites SiteSSL (HTTPS) is on

Hope that was helpful, do let me know if you need anything else. Have a nice day.
Reply
gwendell1 Premium
Date and time looks great. How do I check the sites SSL?
Reply
JeffreyBrown Premium
As you scroll down in settings, you'll see SSL on or off--make sure ON is selected.
Reply
Top