I was looking at some stats of my website pages (posts) and it said that some posts have been blocked from getting indexed because google found a 'noindex' tag in the HTML code of the page.

1. I still don't know how to get into the backside of my website to look at the HTML
2. I don't know how to remove this tag so that google WILL be able to index it.

Anyone have any experience with this?

Thanks You!

X iris G

Join the Discussion
Write something…
Recent messages
feigner Premium
if you open the post for editing on your site...
then scroll down to the seo section at the bottom...
click on advanced ..
and click defaults ...
you see the tags applied to the post...
if the no index tag is ticked ..untick it and update....
next time google visits then it will index the post...
or use the url inspection menu in search console to have a look at your post with googles eyes
phil
Reply
Iris93 Premium
Ok great! I'm going to try that! I also found out how you can manually ask google to index a new post on google search console so that's cool too.

I will have a look in seo first. Thank you so much for this great advice!:)

X- Iris G.
Reply
Iris93 Premium
I followed your steps but didn't find what you said...
Reply
feigner Premium
image of where i would go to check noindex
Reply
Iris93 Premium
I have the latest updated version of SEO [5.8] so it doesn't look the same as yours, it says 'Global Robots Meta' and is turned on to 'Use Default Settings',
Things that are ticked in this 'default' setting are:
1.No Follow Paginated
2.No Index RSS Feeds
3.No Index Paginated

Should I keep these ticked or should I untick them and which ones should I tick (instead)?

The unticked options are:
1.No Index
2.No Image Index
3.No Follow
4.No Snippet
5.No Archive
6.No ODP
7.No Translate

I don't know what any of these options mean and if I should tick them or not...?

Thank you in advance for your help:)

X- Iris G.
Reply
feigner Premium
i have the latest version of all in one seo installed ....
and i think you are looking at the global settings for all in one search appearance....
you can leave the settings in there as they are...

as it is only some of your posts that are not indexeding then the issue is not global but local...
so you need ot deal with each post that is not able to be indexed...
if you go edit the first one and scroll down to bottom you should find the seo panel...
clicking on advanced you will find the above panel...
clicking on defaults shows you the options that are ticked for that post...
and you will need ot do this for each post that google says it cannot index...
Reply
Iris93 Premium
ok I'll have a look, thanks again!
xxx
Reply
Iris93 Premium
I found what you were talking about but they all were unticked, also the >noindex< so how come these pages are still being blocked to get indexed.. where else could the (tag) problem occur?

Thanks X
Reply
feigner Premium
next step is to look at the code for the page ....
visit the page in a browser and press ctrl+u..
a new tab should open with loads of writing... this is how your page is constructed...
press ctrl+f to open the find box and type noindex in there
if any exist then you will be taken to the first one
take a screen shot of what it says ...for windows use the snipping tool
and paste it in a reply....
if none exist then that is not the reason
you could check that it exists in your site map...visit [yourdomain]/sitemap.xml and have a look to see that the page is listed...
and make sure it is not a very slow loading page ...google won't index these...
or very similar ot any other page you have on your site .. .google will only index one of those....
if all those are ok then resubmit your page for indexing...
Reply
Iris93 Premium
it says 0/0 when i looked for 'noindex' with Ctrl f
I did request an manual indexing through Google Search Console, so now we wait right?

still weird nothing come up in the search tho
Reply
feigner Premium
so that means there is no noindex tag on that page ...
so one of the other possibilities...
it may have just been a glitch when the bot visited...let's hope
it should be indexed within 24 hous ...depending on the age of your site...but will be soon...
Reply
Iris93 Premium
ok great! fingers crossed!

Thank you so much for helping me, I learned a lot from this actually:)

Have a great day!

X- Iris G.
Reply
feigner Premium
you have a good day too Iris...
Reply
Iris93 Premium
I did the Ctrl U and Ctrl F thingy with my website (frontpage) and searched for a 'nofollow' tag and i found one!! how do I go about and erase that? I don't suppose I can just delete it can I?

thanks!
Reply
Iris93 Premium
it appears to be attached to my >scroll back to top< button
Reply
Iris93 Premium
I disabled the >scrol back to top< button and now the >nofollow< tag is gone, did I fix it? but I kind of want that button on my site for the visitor's conveniënts
Reply
feigner Premium
thats a link with a no follow ..so that will be ok...
you can reactivate that again...
no follows are ok...it was noindex you are looknig for ...but i think it was a glitch in google when it visited...
Reply
Iris93 Premium
but it's just weird that almost all my pages have a few nofollow tags and I saw an article where it said that pages with a no follow tag in them can't be backlinked. That's maybe not important now but later on...?
Reply
feigner Premium
that's not right...
if you link to a site with a nofollow hten google ignores the lin and doesn't follow it...
but a lnik on your site that has no follow is saying to google don't follow this link...
the only backlinks that are really worth something are the very high authority ones....
so don't worry about those...
you want ideally to nofollow most of your links...
i tend to leave wiki links, but even those can be marked as nofollow...
Reply
Iris93 Premium
thank you :) still don't completely understand but I will probably find out along the way somehow haha
Reply
Top