I set up an email on my domain but found that it will only work through messages on WA platform. Why don't my email work as a normal email account? I have sent messages to the account but it does not work?

Join the Discussion
Write something…
Recent messages
ChrystopherJ Premium
My email hosted here is working ok, I have it configured with my Outlook 365 and my iPhone. Which client are you using?
Reply
JerrySr Premium
Thanks for your quick reply ChrystopherJ, I thought it was outlook but I'm not really sure?
Reply
ChrystopherJ Premium
Which program are you trying to add it to on your computer? Is it Microsoft Outlook or something else? Are you getting an error message while adding it?
Reply
JerrySr Premium
Yes Microsoft Outlook is the platform I'm trying to add it to.
Reply
ChrystopherJ Premium
WA store your emails on the same server as your website, but use their SMTP servers for sending emails. You, therefore, have different credentials for Incoming and Outgoing mail servers.

If you close Outlook and open Control Panel and search for Mail, you can open up the properties for your current profile where you can edit your email account settings. You need to ensure that the Incoming Username is your email address with the correct password, then you need to select my server requires different credentials for Outgoing mail. The username is your domain name and you need to use the correct password.

Once saved, you can open Outlook again and all should be working.
Reply
JerrySr Premium
Thank you so much for your assistance. I was having a difficult time figuring out how that works.

"Keep On Keppin On"
Jerry
Reply
ChrystopherJ Premium
No worries, is it working for you now?
Reply
Top