I know there is going to be a webinar covering everything you need to know about SSL but there were a few questions getting asked in chat yesterday so I thought I'd do a quick check list for everyone.

The first thing to remember is that you can only add SSL to domains that you own.

The Siterubix free domains are subdomains and therefore not elegible for SSL certification.

Switching is a one click and very smooth process.

Go to your Site Manager and you will see a new button called "SitePlus+"

If you click on the blue SitePlus+ part you will be taken to the next page where you can turn SSL on

As you can see I have already turned mine on for this

It's a very smooth process and only takes about 30 seconds

But now the fun starts.....




Join the Discussion
Write something…
Recent messages
NemiraB Premium
Hi, thanks for the training. However, I wonder how to verify a new site because previously the same site was verified and codes sit nicely in the head. Do I need to squeeze a new verification code close to old one? It seems that they are the same.
P.S. I switched to SSL the long time ago but I did not add it to Google Search Console. Now when I added, I need to verify. However, the site is the same. Do I need to remove the old verification code and past a new one?
Reply
Alan Hocking Premium
No you can verify it using the Google analytics method that way there is no need to add any more codes
Reply
NemiraB Premium
I see, thank you, all the best:)
Reply
Alan Hocking Premium
You're welcome :)
Reply
tommo1968 Premium
Alan wish I had found this training a few months ago would have saved me some heartache. LOL!

I would like to point out that although I did add the new https to google analytics I also had to add the search console section at the bottom of the property also later as I found my queries data had all but disappeared. You can see what I mean on this post I did.
Reply
Alan Hocking Premium
Ahh okay I hadn't come across that problem so thanks for the heads up :)
Reply
My-Mate-Bert Premium
Hiya, Alan - great info here - SSL can be such a nightmare, especially when like me, I've got to hold visitor data myself so cannot afford to have padlocks showing on any browser.

Just about to bring 4 sites in from the cold outside into WA hosting so this info very handy, thanks.

I may end up asking your help if it's OK later when I muck it all up. SSL certs are horrendous when trying to install one at the hosting platform I'm currently using so gotta give WA hosting a go, eh?

I have a feeling it may be better for me in the end to double check EVERYTHING on EVERY page of every linked social media site + all other sites I link back to my sites from manually just to be safe but the links you've given here are gonna help sooooo much.

Your checklist is brilliant so I've bookmarked this training for reference again and again.

Thanks ever so much and catch ya soon - All the best - Andre (Oh 'n' Bert, he says).
Reply
Alan Hocking Premium
Thanks for the comment Andre

You should find the switch to ssl very smooth here at WA but if you have any problems just shout

I'm more than happy to try to help with anything I can :)
Reply
My-Mate-Bert Premium
Hiya, Alan - it took under 1 minute to do what took me 2 days outside of WA. Wow. with wow attached, eh?

That's the value of 2 months premium membership paid back already on 1 site and I'm bringing a few in today. DNS transfer was just 2 hours per site. Easy and fast.

Thanks for your great info here. You've done me a REAL favour, thanks.
Reply
Alan Hocking Premium
You're welcome Andre glad you're getting it sorted
Reply
MrRichGuy Premium
Hi, I seem to be having this issue. My website shows "https". However, it doesn't show the green padlock. I have gone through the training before and waited several days and it still didn't work. Do you have any tips to help me out? That would be much appreciated. My website is linked below. Thank you very much!

https://ultimatemartialartsacademy.org
Reply
Alan Hocking Premium
Hi Wilpa

The nopadlock website that I give you a link to in the training should tell you what needs fixing.

Also check that any logos/favicons and header images that you have uploaded in your theme settings have https in their urls and also check all your links and images in your widgets
Reply
Freedomseekr Premium
Hi, LadyPhoenix,
I took a peek at it, and I'm thinking it's most likely your banner image in the sidebar widget...the one that has "start your dojo" by right-clicking the image to check "view image info" it has an http in there, so I'm guessing it's that, since each page I went to didn't have a green padlock...so it's one that shows up on all pages/posts as far as I checked.

Hope that helps some along with the nopadlock site Alan mentions.
Best wishes :) ~Sherry
Reply
MrRichGuy Premium
Thank you! I removed the advertisement. Thank you for your help!
Reply
Alan Hocking Premium
Glad you got it sorted out Wilpa :)
Reply
VeronicasLuv Premium
Hello Again Alan,

II was able to make the changes on Site Manager, and I see the green lock, and my site shows "https".

I seem to be having issues with logging into Google Analytics; I'm awaiting some feedback from the community regarding this.

Eventually, I'll have to get that resolved, but for the purpose o me being able to add banners to my site, can I do that now, even though I haven't been able to make the changes in Google Analytics? I just want to ake sure that there wouldn't be any issues with the codes.
Reply
Alan Hocking Premium
You should be fine adding banners to your site Veronica it doesn't have anything to do with you logging into Google analytics

Hope you get your analytics log in sorted out soon :)
Reply
VeronicasLuv Premium
OK, thanks Alan.
Reply
whitsunday Premium
Hi Alan. Thanks for this training. I have done each step.
Strangely, I have no data displaying on webmaster tools for my new https. Search analytics is blank.
On the http site it shows 71 webpages submitted but only 40 indexed.
Where do you think I should start, to correct this problem?
Reply
Alan Hocking Premium
Hi Janelle

It will take a while for Google to start collecting data on your new https property

Check it again in a day and you should see some results

Alan :)
Reply
viralviral Premium
As Jay said in the last webinar, its better add a new proprierty that changes the currently configs on webmaster tools: at 30'00
Reply
viralviral Premium
Oh no, its two different things, one is analytics, other is google webmaster tools, my bad.
Reply
Alan Hocking Premium
Yes you should add it as a new property Andre
Reply
Alan Hocking Premium
No problem Andre

As long as you've got it worked out now that's fine :)
Reply
Gretchen33 Premium
Thanks for the training, I am having trouble with one of my pages. here is the error message,
astore.amazon.com returned an error (Possibly 404 not found or other webserver error. The thing is I know there is a problem with that page as my store isn't functioning properly since I turned on SSL, do you have any suggestions on how to fix this? None of the links are working on my store except the links on the main page. None of my browse by category or page number links work. If I turn off ssl all is fine. I would really like ssl to work since I have a store.
Thanks
Reply
Alan Hocking Premium
Sorry Gretchen I don't use Amazon Astore so really can't help you with a solution

It's probably better to ask the question in the community where other people who use Amazon might be able to answer your question

Al :)
Reply
mrbill6771 Premium
Thanks for the heads up, Alan. I hadn't thought much about it. I found I need to change affiliate urls, email urls, SiteRubics urls, and a whole bunch of other links. It's a pain, but worth it in the long run. I needed to go back through all of my websites for the New Year anyway. This is the motivation I needed.
Bill
Reply
Alan Hocking Premium
Thanks for your feedback Bill

Yes unfortunately it's not just a case of pushing a button and that's it

There's a few other things that need updating

Glad you found my checklist useful :)
Reply
MisterReen Premium
Hello Alan, thank you for this very helpful tutorial. My site is shown to be secure. However, two of my banner pictures don't show up. The error message displayed when inspecting is this:

Failed to load resource: net::ERR_INSECURE_RESPONSE

Trying to change the embedded links to https does not work. The banner pictures link to another website. I had to save and upload them into my media library from my website. After that it worked.

I am not sure if there is another way to get around it.

Rene
Reply
Alan Hocking Premium
Hi Rene

Unfortunately if you are loading banners from an outside source that doesn't have an SSL certificate you will always get that message

The only way around it is to download the image/banner then upload it as a media item and then add your affiliate link to the image like you have done
Reply
Zarina Premium
Thanks for sharing this wonderful resource!

One thing to note - I am pretty sure Carson mentioned that we don't have to worry about changing to httpS on our shares whatsoever - it should automatically do that.

And now a question... In Webmasters we add httpS as a new property - but do we have to re-submit our posts for indexing?

Also, do I delete the http://... one from webmasters?

Thank you!
Zarina
Reply
Alan Hocking Premium
Hi Zarina

Yes your social sharing buttons should all update automatically

You don't need to submit all your posts to webmasters again just your sitemap with the https prefix.

I would leave the http property there just in case you need to switch back in the future

Hope that's answered all your questions Zarina

Let me know if you have any more?

Alan :)
Reply
Zarina Premium
And if I'm not lazy to index a couple of them, that's still fine to do (even though the the posts were indexed in the http form before)?
Thank you very much! :)
Reply
Alan Hocking Premium
Yes of course

The https version of your site is technically a completely different site to the http version so if you want to fetch some of your posts it will certainly speed up the process of getting them indexed and ranked

All your http urls are automatically forwarding to the https urls now anyway so eventually the http versions of the posts will disappear from the serps as they get replaced with the https versions
Reply
Zarina Premium
I see - thanks so much for explaining this. You are awesome, Alan!
Reply
Alan Hocking Premium
You're welcome Zarina glad to help :)
Reply
Grazinka Premium
Hi Alan,
I have a beginner question, so please bear with me.
It seems your post is in the 'Classrooms' section> Uncategorized > "The Switch to SSL...". I can hover over 'Classrooms' but there's no uncategorized section/category that I can just point my mouse, click and go to directly, which leads me to my question- how do I find your post if I like to come back for a reference?
Also, maybe another silly question, coming from a beginner. Again, I tagged your post for a future reference but now I wonder where I can find it.... Nowhere in my account that I could find "yellow stars" section with all my tagged posts, articles, etc....
I'd appreciate pointing me in the right direction.
Thanks!!
Reply
MikeMahaffey Premium
try typing the words you used to tag this post with into the search bar
Reply
Alan Hocking Premium
Hi Grazyna

If you have tagged this in your favourites just click on the star symbol in the search bar and it should show up in a drop down
Reply
Grazinka Premium
Ha! Thanks! :))
Reply
Alan Hocking Premium
You're welcome! :)
Reply
Sorayacge Premium
Hi Alan, your training was perfect and I followed it without problem but then I received this notification. Any ideas? I will post in in the classroom too...

Google has noticed that the SSL/TLS certificate for https://lovepositivethinking.com/ has expired. This means that your website is not perceived as secure by some browsers. As a result, many web browsers will block users by displaying a security warning message when your site is accessed. This is done to protect users’ browsing behaviour from being intercepted by a third party, which can happen on sites that are not secure.
Recommended Action:
Get a new certificate

Any advice please?
Thank you,
Soraya
Reply
Alan Hocking Premium
It's actually showing up perfectly secure for me but I would show that message to support they're really the only ones who can help you with it

Are you sure the message came from Google or somebody trying to sell you another SSL certificate?
Reply
WriterLynn Premium
I just posted this 45 minutes ago: The emails were from Google search console. Not a spoof....
Google Search Console Team sc-noreply@google.com
Reply
Alan Hocking Premium
Okay well I would definitely contact support then Nicole and see what they have to say

Try to show them the email you received and let them give you the answer

I'm sure it's nothing to be concerned about :)
Reply
Sorayacge Premium
Hi, Thanks Alan and Lynn,
Silly question...but what do you mean by contact support? Where is it?
Reply
Sorayacge Premium
Ignore my question...if you mean support on SiteRubix....
I'd assumed this issue was to do with the WA certificate.
Reply
Alan Hocking Premium
Yes I meant the WA website support here:
https://my.wealthyaffiliate.com/websites/support

It's WA that's issuing the SSL certificate
Reply
Sorayacge Premium
Thank you Alan. Kyle has answered that my website is fine, so I guess I don't have to worry about it...
Reply
Alan Hocking Premium
Ahh great news so onwards and upwards!
Reply
Grazinka Premium
Very nice website, Soraya!
:)
Reply
Sorayacge Premium
Thank you Grazinka!
Reply
boomergp08 Premium
Thanks for this Alan. As I am with most things in regards to updating/upgrading, I have yet to change to SSL. It is not a must do now upgrade, as Carson indicated in his post. But it will be eventually.

Once I have a full day to sit down and make the change, as well as check that all other aspects are working correctly, I will make sure to access this tutorial. Thanks for covering many of the associated points.
Reply
Alan Hocking Premium
Thanks Robert

Yes I made sure I had a whole day free before I switched over just in case there were any snags ;)
Reply
WriterLynn Premium
Thanks Alan. I was concerned about the Google and Bing webmaster tools and your training made it very simple. One question though....What do we do with the original non-https properties in Google webmaster tools? Do we just leave them there or do we delete them after the new https properties get crawled?
Reply
Alan Hocking Premium
I would just leave them there in case you ever need to switch back to http
Reply
Chrissies Premium
Hi Alan
I can see the padlock in editor but it is not there when I go to view the site. I am not completely sure how to view it incognito.
I checked the site you mentioned, and it appears that there is one banner which I have which is not secure, and I'm not sure how to deal with that.
If you have any ideas I should be most grateful :)
Reply
Capu1 Premium
Chissie,
this is a problem I have been dealing with. I have checked with Google, Bing and other technical experts, including our support center and no one has come with an answer. al I get is that my site is new and it will take time for that mark to go away.
If you find a solution, please let me know because I do not know what else to do.
Thanks,
Lisa
Reply
Alan Hocking Premium
Okay this is probably a header banner or logo so try looking in your site settings to find it and just add the "s" to the end of the http part of the url

The tool should tell you which image/banner it is
Reply
Freedomseekr Premium
Very helpful Alan! I still need to do mine since I knew there has to be other things to do along with clicking the button to turn it on...glad I waited a bit to find this! Thanks for taking the time to do such an awesome tutorial!

Best wishes :) ~Sherry
Reply
Alan Hocking Premium
Thank you Sherry I'm glad you liked it! :)
Reply
ShlomoJ Premium
If I haven't reached the training where I am told to sign up for google analytics do I have to worry about that?

Also, what is Webmaster/Search Console and do I have to worry about it at this stage?

Thanks for this training it was a really easy and helpful read.

Shlomo J
Reply
Alan Hocking Premium
Don't worry about it at this stage Shlomo it will all be in the training as you work your way through it
Reply
ShlomoJ Premium
Great. :) So as far as SSL goes I'm good to go... right?
I mean if I don't know what those are, then I don't need to update it I guess... lol
Reply
Alan Hocking Premium
Yes you can update to ssl now and then you will naturally cover the other parts in the training as you carry on working your way through it
Reply
ShlomoJ Premium
Thanks for the help. :)
Reply
Alan Hocking Premium
You're welcome :)
Reply
Top