Google Analytics is the most powerful website analytics tool out there (and it is free). In this video I will walk you through the entire set-up process, from the initial account set-up.

To set up Google Analytics, you simply need a Google Account. You can either use an existing gmail or Google + account and connect your analytics to that (easiest) or you can create a brand new Google account within the set-up.

Here is the link to Google Analytics:

http://google.com/analytics

Once you have the account set-up, you will be adding the provided "code" to your websites header.php file which is found under Appearance => Editor inside of your WP-Admin area.

If you have any questions about the set-up process, please leave a comment below and I will be more than happy to help you out.
Join the Discussion
Write something…
Recent messages
prime1 Premium
Kyle I need Help!
I followed the above video and pasted the code accordingly but it is not updated under real time - overview to show anything as it is still at zero????

<head>
[removed]
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m[removed].insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-97510386-1', 'auto');
ga('send', 'pageview');

<meta charset="<?php bloginfo( 'charset' ); ?>">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="<?php bloginfo( 'pingback_url' ); ?>">
<?php wp_head(); ?>

[removed]
Reply
Labman Premium
Why do you need to enter it manually, just add the UA code to the All In One SEO pack and you are done.
Reply
amgolf Premium
I add code to Yoast SEO, in the plugin space.
Reply
varleysheen Premium
I cant find where you add in yoast
Reply
prime1 Premium
Thank You It worked!
Reply
SamSaxon Premium
Thanks :)
Reply
TammyM2 Premium
When I go to Appearance=>Editor it tells me That I should not enter Editor unless I'm a professional and to contact site support. Would anyone know what I'm doing wrong?
Reply
BobBarr Premium
You're not doing anything wrong. That is a warning message that you need to proceed with caution since any errors that you make in the editor can have very bad effects on your site.

Just note the warning and proceed with caution.

[added]
Note: If you have the All in One SEO plugin active, you don't need to use the editor to do this. All in One has a capability to add your Analytics code without editing files. An added benefit of using All in One is that you don't need to re-enter the code every time your theme gets updated.
Reply
TammyM2 Premium
Thank you so much I figured I broke things before I even got started! I do have the plugin so worries!
Reply
BobBarr Premium
The All in One plugin has a section for entering verification codes. Be sure to only enter the code characters *between* the quotation marks. Including either of the quotation marks on the ends of the code will prevent the verification from working correctly.
Reply
TammyM2 Premium
Thank you for jump starting me again! Have a great evening :)
Reply
anthony97 Premium
Hi guys I had the same problem but have All In One SEO, where do I add the verification code?

Thanks
Reply
BobBarr Premium
In the wordpress dashboard, hover over "All in One SEO" and click on "General Settings". (#1 below)

Scroll down to the "Webmaster Verification" section and type or paste the verification code in the box. (#2 below)

Scroll all the way to the bottom and click on "Update Optionss" to save. (#3 below)
Reply
TammyM2 Premium
Thanks so much for the help! Got it done now :)
Reply
kdavis30us Premium
pretty neat...
Reply
AfqmBiz Premium
Done. Adjusting for better performance and make it work
Reply
brosam Premium
I've done this and it hasn't worked?
Reply
CGleason Premium
For WA hosted sites that automatically have the All In One SEO plugin pre-installed, it's easy to add your Google Analytics code to the plugin so that all pages are included in tracking without having to add code to page headers.

https://semperplugins.com/documentation/setting-up-google-analytics/ provides an up-to-date instruction on getting a Google Analytics ID and once you have the ID there is a field in the general settings tab of the ALL in One SEO plugin where you copy and paste the ID.

Once you've added the ID there, you should start seeing activity in your Google Analytics account.
Reply
earnest1128 Premium
thx,you really saved me a lot of headaches on this
Reply
Olaf1 Premium
can I go back to some learning videos ? where I can find all this learning videos ? I wont to go over some information , thanks !
Reply
drjec Premium
You can go to the left of the home page to classrooms and look for what you want. You can also looks at the certification courses there. As well, you can type in the subject of a course in the search bar at the top of the page. A list related to your search will come up.
Reply
Greg2112 Premium
What about when you update your WordPress Theme? Wouln't have to update header file with your Google Code ?
Reply
amgolf Premium
In my suggestion just redo Google Analytics. Again.
Reply
Greg2112 Premium
This is good info but you guys really need to update some of your videos as the layout in Google has changed.
Reply
JackieSmith Premium
Hi Kyle,
Where in the header.php file do we add this code? Is it the verification code that is displayed after we have uploaded the html file to the server? I'm not sure if this is related but I added my website to the Webmaster tool about a week ago. I have since updated the theme but when I go into the Webmaster tool, it's still showing the old theme, so I readded the site..it's still showing the old theme. When I go to Google Analytics, even though I am on my website, it doesn't show that there is an active user. Can you please help/advise.

I'm using Yoast NOT the ALL in One SEO. The site in question is hosted here.
Another site of mine that is hosted elsewhere and is using Yoast seems to be working fine in that it shows the Active user count correctly.
Thanks
Reply
Chezbrown Premium
Hi Jackie, if you haven't managed to get this sorted out yet, go to Marion Black and she has an excellent training for this. I found it easier than Kyle's to follow. xx
Reply
MsMerry Premium
Did you also refresh your site after the changes? I use Yoast as well and had no issues. It is probably something simple and you will laugh about it later. :)
Reply
JackieSmith Premium
Thanks Chezbrown. Yes. I was following Marion Blacks training which are brilliant. I will review them again.
Reply
JackieSmith Premium
Thanks MsMerry. I do not have a problem with Yoast on my non- WA hosted site. The problem is with the site hosted here. Even when I remove the site from Webmaster Tools and add it again, it still shows the template I used when I first registered the site so I'm thinking it's something on the WA end. I will try again, maybe third time lucky.
Reply
Kambas Premium
On mine it said Theme Header and the <head> is there. Seems to have worked, I popped up as a visitor on my site immediately after clicking "Reporting".

Thank you Kyle.
Reply
Stansk Premium
Works great Kyle thanks a lot.
Reply
KachinaB Premium
I actually had to add my tracking number in my All in One SEO. I did not see the "header" tab in my editor section of my website. I didn't want to break my website so I tried another method. This one works just as well. I wanted to share that to everyone who may have seen something different. Check out the link below for more info
Reply
Gerlinde Premium
You are right! I prefer this option as well! Otherwise with every theme update you have to do it again...
Thanks for the link!
Gerlinde
Reply
KachinaB Premium
finally made it to this step!
Reply
Godwin2 Premium
mine is working
Reply
Milar Premium
My country is not listed, what do i do? so i selected a neighboring country to see what happens, when i get to click Appearance and then Editor...it takes me to "Edit Themes" http://workathomeonline.siterubix.com/wp-admin/theme-editor.php and Kyle's interface looks (old) different from mine
Reply
I tried to add a Google Analytics tracker to my website but WP would not allow me access into the Editor to do so....
Reply
Andy3568 Premium
You can request support here to allow you access, or you can add it via the All In One SEO Plugin. Here's a video on how to do that.
Reply
WAwannab Premium
It seems okay, however, I don't see a #1 even after going on my site. I did have analytics before getting to this lesson and with the help from Jays training, I am now better able to see and understand the traffic. According to what I am seeing on Analytics, it seems to be working correctly, though.
Thanks Kyle!
Reply
Cmann1 Premium
All done......:)
Reply
MrGlenn Premium
Got it installed, another step accomplished.
Reply
AlohaMelani Premium
Thanks for this step by step training! Since Google Analytics has changed a bit since this recording I was able to read the messages below to finish the set up. Very easy!


~Aloha
Reply
jonmovumI71 Premium
Hello Kyle,
Greetings.
I cannot setup Google Analytics as Edit option is disabled!

Could you please help?

Best regards,

BN
Reply
Lilika84 Premium
Thanks, Kyle.
I installed this a few weeks ago; it was a bit different process (as I remember I haven't added code in the WP editor)
Anyways, wanted to ask if it is a mistake to have it installed again (this time I added the code as per your training).
Now I have two accounts for one site.
Is that ok?

Thanks you :)
Sunny
Reply
Starrider Premium
I went through all the steps and everything seemed to work but when I log into my website to test it like Kyle did, my traffic shows "0" not "1". Does it take a while sometimes to show? If not any ideas?
Reply
Ken-Pringle Premium
Yes it can take a while Dennis.
Reply
Starrider Premium
Thank you Ken. I will check in the morning!!!
Reply
Dean702777 Premium
Awesome...Works like a charm!....Thanks Kyle!
Reply
Watto71 Premium
Can anyone please advise as i have followed everything Kyle has detailed however i don't have a 'header' file on it's own, i do have entry header, does anyone know if this is it ?
Reply
djvinson Premium
You went to (Appearance, then down to Theme Header "header.php) ?
Reply
djvinson Premium
Sorry told you wrong it is Appearance then Editor then on right side Theme Header (header.php) If you haven't sent support a message yet they must unlock it for you.
Reply
Watto71 Premium
Hi All, many thanks for the reply's i still had issues manually putting in the link as my site didn't seem to come up with the header.php so i followed Andy3568 which is the SEO plugin and this has worked really well, please see link below kindly donated by Andy if you need it.
Reply
djvinson Premium
Do you have to have your site on your own domain for this to work? It says I don't have access to do this.
Reply
Vinicortez Premium
It is awesome seeing similar reactions below. This is exciting!
Reply
dapto Premium
At first I had the same problem with you too. You have to submit a ticket to ask them to turn On the theme editing for you. The response was quick and I was able to install manually.
Reply
djvinson Premium
This answered my question.
Reply
Joekaprod Premium
Unfortunately, I cannot add my code in manually because of my safety. Why can't I edit code?
Reply
Andy3568 Premium
I had the same problem. I thought everyone had that problem, but I see most people are able to add Google Analytics manually, so I am not sure why only some are denied access to editing code. Here is an alternative way to add Google Analytics to your site: It is a little outdated too, so you won't see things like "Use Universal Analytics" because that is automatic now, but you can still get Analytics on your site by following this training.
Reply
Joekaprod Premium
Thank you, Andy! That tutorial really helped out! Now i got Google Analytics on my site! :D
Reply
kchatman Premium
This was so helpful..thanks
Reply
Andy3568 Premium
You're welcome! Glad I could help.
Reply
nakijo Premium
Yay, it works... getting excited now :)
Reply
Jray0728 Premium
Hey all, I imputed google analytics and its not testings out positive. Any suggestions?
Reply
Nrichards Premium
Hello have you tried cutting of your computer and restarting it again this may help.
Reply
Jray0728 Premium
Excellent, will try that. Thank you.
Reply
Nrichards Premium
You are welcome all the best to you.
Reply
MNorton Premium
Hi Kyle,
I'm so excited!! I installed Google analytics to my site, tested it and it works!! I was so nervous, when I was getting it done, but I did it!! My face hurts from smiling so much. This is the first time I have ever done something so technical before on my computer. I'm so happy, I had to stop and do my "happy dance"...Lol!!!
Have a good day.
Mary
Reply
when I try to enter my website url in analyiics I get this message

Website URL

Default URL is invalid.
Reply
Mburul Premium
I can't see myself in real time. Not sure whether its working.
Reply
DLoo Premium
It's only tracking me when I'm on my main page. It goes down to 0 whenever I try to go to another page on my website.
Reply
KeiKei Premium
This isn't working for me I denied access
Reply
Juneyo Premium
Try this one using the All In One SEO.
Reply
KeiKei Premium
I will try that Thank you
Reply
Juneyo Premium
You're welcome =)
Reply
KeiKei Premium
I got it thank you
Reply
Andy3568 Premium
For some reason, I am denied access to the Appearance Editor. Is there another way to access it?
Reply
AndiTointon Premium
I think I might know what the problem is because it happened to me too. In actual fact you are not....what you need to do is click the
keyboard icon on the right end of the ones that you do have and you should then get the other buttons drop down such as the headings the bold the underline colour etc. Try it and let me know if it is that?
Andi.
Reply
AndiTointon Premium
Andy3568 did you sort it out at all?
Reply
Staceyjohns Premium
Thank you, Kyle, for the step by step instructions. I did it and I did it right. My hands were shaking but I did it.
Reply
MNorton Premium
I know that feeling, mine were doing the same thing...Lol!! I got it done too!!
Reply
CateR Premium
This video: you add some code that contains a "Tracking ID" to the header.php

The one below: ... you add some (different) alphanumeric to the Google Verification in the SEO

Do they both do the same thing?
Should I insert both?
Reply
Juneyo Premium
The one using the All In One SEO you just have to copy the tracking ID number. Whereas this one is the manual way which you’ve to include the script code and the tracking id as well.

Yes, they both do the same thing. So, just choose one.
Reply
CateR Premium
Okay - something odd there...
"The one using the All In One SEO you just have to copy the tracking ID number."

The Tracking ID is not the same number as the "google site verification" that Marion shows us to paste into the SEO Google Verification spot.

2 different alpha-numerics.
Reply
Juneyo Premium
Pardon me for my ignorance. I just realized you’re talking about 2 different things. I thought the All In One SEO link is talking about verifying Google Analytics with AIO SEO until I click on it.

The answer is yes, you have to do both because they are 2 different platforms. This video is about verifying your GA manually whereas Marion’s video is about verifying Google Webmaster Tools using AIO SEO

Do the GA verification first and then GWT verification.
Reply
CateR Premium
Oh cheers! You are a star.
(I really had no idea WHAT I was taking about!)

May I ask you another one?
Kyle shows us in his video - put the tracking code in header.php under <head> and above php..... mine don't look like that....

In mine, php is right at the top of the page and <head> has some other stuff under it.

So... do I put it "above php" or .... under <head>?
Reply
Juneyo Premium
You should put under <head>. Don’t worry about the stuff under it. Put your cursor at the end of > and click enter once and paste the code.

There is the easiest method using the AIO SEO. Here’s the tutorial.
Reply
CateR Premium
Hi Juneyo,
I put in the Tracker ID and the verification code....into the SEO.
But verification fails when I press "Verify" in Google.
Help?
Reply
CateR Premium
Nevermind question below - I got it to verify!
Thanx for your help! :-))
Reply
Chezbrown Premium
I did the google verification using Yoast which set up analytics, is this the same as the way Kyle did it as I never put anything in the header part?
Reply
devastart Premium
This was for me easier way :)
Reply
AndiTointon Premium
done it times 4
Reply
upsgirl Premium
Do you need help?
Where are you stuck? Which part?
Reply
devastart Premium
I have a problem! How to cancel a manually entered Google Analytics? I think I enter the Google Analytics code in the wrong place, because when I go on reporting is 0, I think I made a mistake. How to undo entered and where to re-find Google Analytics code that I have to enter. I enter the code under Appearance-editor-theme Header?
Please help
Reply
devastart Premium
I managed to solve the problem. I found in my Analytics tracking ID, and I copy and All In One SEO.
Reply
SandraAngela Premium
Bok, Tanja! Žao mi je, ali na ovo pitanje stvarno ne znam odgovor jer to nisam još radila ni na svojim web stranicama! Kako si ti? Kako napreduješ sa izradom svog sajta? Puno pozdrava!
Sandra
Reply
devastart Premium
Bok Sandra, uspjela sam rješit problem, hvala na pokusaju :). Dobro sam, radim, ne ide baš brzo koliko bi ja htjela i još puno imam za naučit, izrada ide, dok zarade još nema. Nadam se da će se i to promjenit u skorije vrijeme. Pozdrav i cujemo se.
P.S. Nadam se da si to dobro i da tebi ide i izrada i zarada ;)
Reply
meg68 Premium
Thanks to the author of this video Kyle for the great step by step instructions. After having much trouble trying to set up tracking via All in One SEO through Google+, I decided to try doing it manually via Google Analytics. The step by step instructions on this video are great and I'm now set up. The only step I did on my own was adding a filter on GA to exclude my IP address from tracking. I worked that out by Googling for instructions.
Reply
AAmouzou Premium
I used Google Analystics for a funnel before. Now I don't know if I should delete that data or just add this website. Thanks for anyone who will help with this.
Reply
upsgirl Premium
If you still need that information, keep!
You will add your new business.
Reply
AAmouzou Premium
Thank you upsgirl, for your answer. I just added this website it and it is working.
I have another question like how many website can we add to google analystics?
Reply
upsgirl Premium
Great!
There isn't a limit.
You're welcome!
Reply
seconds2work Premium
Looking for some advice. It looks like I have installed a plug-in to perform this task. I am trying to use less plug-ins. To prevent from breaking my site, what is the right way to deactivate the plug-in? I would like to get my stats using the way Kyle has shown us in this lesson.
Thank you, LeNard
Reply
upsgirl Premium
Just click DEACTIVATE.
Reply
seconds2work Premium
I thought so. Just wanted to be for sure. Thank you
Reply
upsgirl Premium
You're welcome!
Reply
sjenkinsjr Premium
Finally I took care of this, I must have forgot or never finished setting it up but moved on with the training. Who knows but it's set-up and working.

Took a little while to register, at first it wasn't showing any visitors, I had it on my phone and my laptop which then it showed 2 visitors.

As always thanks for the valuable training Kyle....
Reply
Jena1 Premium
What do I do if I don't have a header page? Is there anywhere else I can insert the code?
Reply
Juneyo Premium
Yes, you can use the All In One SEO. Here's how
Reply
MsMerry Premium
thanks for sharing this Juneyo. I am going to look at this as well. I am so not techie! I followed the training but could not get the verification at Google. Every little bit of info helps to understand more.
Reply
Juneyo Premium
You're welcome =)
Reply
MsMerry Premium
I got it too work. At least it says congratulations!
Reply
Juneyo Premium
Great! That means it works =)
Reply
MsMerry Premium
yup, I just checked mine Zach and the same thing. Not sure if I added my code in the right place as I have two <head> Does it go under the first one or second one? Maybe my template is different. Just not very techie so this a hard part for me.
Reply
ZachMathews Premium
He MsMerry, what are you adding? Is it Jaaxy key tool? :) Im not sure I ever added anything like your describing except maybe banners or the like.
Reply
MsMerry Premium
oh, the google verification code Zach. I am going to have a look at the All in One SEO and see if that works for me.
Reply
ZachMathews Premium
Oh gotcha, I havent done that yet, maybe my answer is waiting for me there!
Reply
MsMerry Premium
LoL sounds good to me Zach. So much to learn. Thank you. I did get the analytic s part for google done via SEO. Now to learn more. :)
Reply
ZachMathews Premium
hi folks, so just curious, in my analytics it says I've had zero-zilch traffic.. Anyone else have that too? Im just wondering if I should have had some visitors by now in the bootcamp.. :-/
Reply
upsgirl Premium
It takes time!
What is your url?
Did you follow the training?
Reply
ZachMathews Premium
hey upsgirl, thanks for your response.. yeah I've followed it all to the T, except I am still setting up some of the social media.. My url is workforyouandloveit.com
Reply
upsgirl Premium
I am not finding you in Google.
You missed the Google Trainings...go back to the second Course.
You need the Google Webmasters and Analytics' Trainings.
Reply
ZachMathews Premium
Bootcamp level 2 courses?? Just double checking, im not sure what I couldve missed... Thanks for taking the time to help me out! ... Grrr, all this work and im not even in Google, how does this happen?... You know what else is weird, I have another site on here that is dormant and has no content. So this dormant sites health is bad of course, BUT it's site trust is 80%! Yet this current site I'm working on has good health and content, but only 20% site trust! I wonder if Google is confused or something? I wonder if this is an issue for Kyle......
Reply
johncruz Premium
Your site is doing just fine man, so don't even worry about it. Things just need to get updated and then you will be at ease. I say, focus on building out your site more and don't even worry about checking on what the doctor says. You're doing great, trust me!
Reply
ZachMathews Premium
Thanks for the encouraging words John! like they say, when the going gets tough the tough get going ;)
Reply
upsgirl Premium
Just checking in...nothing in Google yet.
Do you need help?
Reply
ZachMathews Premium
Well, Im not sure what help I need, LOL! I might try some SEO stuff out here in some WA trainings from other members, and maybe hit up Kyle at some point if things don't start turning up... I'll keep you posted and thanks a bunch for offering a hand :)
Reply
upsgirl Premium
You're welcome!
Why wouldn;t you make sure your site is indexed? Nobody knows it's up and running!
Reply
ZachMathews Premium
well when I look in my site health it says indexed in Google 100%, is that what you mean?... correction it says ranked 100%...
Reply
upsgirl Premium
Google Index...Yes or No?
Reply
ZachMathews Premium
I clicked on the index question and it showed the main url in google, im not seeing any of my articles though.
Reply
ClaudiaHB Premium
Hi, I got a question, I need to do this for three websites, so far it worked well for the first one, but how do I add two more websites to the google account? Thanks
Reply
upsgirl Premium
Login to your Google Analytics' account.
Look in the top, right corner.
See the little arrow?
Click there.
ADD GOOGLE ACCOUNT.
Save.
Reply
NINEK7 Premium
Hi!
I have followed every step in the video but I have a problem - when I check the visitors on Google analytics site it doesn¨t work. Well accually it shows some visitors but it is showing that they are from USA and I am from Europe, so it doesn¨t track me.

I have noticed that everytime I hit the refresh button on my SiteRubix site manager Google analytics shows 1 user from USA Ashburn....it seems that this two actions are connected, but I don¨t understand how???
It should track my computer ID (Slovenia - Europe)
Does anyone have any idea what could be wrong?

Thank you!
Nina
Reply
MisterReen Premium
Hi Nina,

I don't know what could be the cause. It could be a siterubix thing if you did not register your own domain yet. I just checked in google and it seems like that they are hosted in Ashburn. So it is actually you that you see.

Once you get your own domain this should not be an issue, although google should still be able to track you from Europe. Try to visit your website when you are not logged in, does this make a difference?
Reply
NINEK7 Premium
Thank you very much for your help! Yes that was my thoughts exactly - that the problem is in siterubix subdomain.
I have tried to visit the site logged out, but it is still the same (location : USA - Ashburn).
But when I visit site from my phone via 3G network it recognizes my location and the interesting is when I visit the site from my phone via home wi-fi (the same IP as the computer, because at home computer and phone are using the same network) it still recognizes my location in Europe!!!. So you see it does not make any sense.
Accually it doesn¨t recognize my computer at all if I don¨t hit the refresh button on my SiteRubix site manager - and when I do this it recognizes me located in Ashburn.

I don¨t know what to think - is Google Analytics working properly or not? I just want to make sure that everything is ok as I am going to use this tool very often in the future and will have to rely on it!

Thanks again!

Nina
Reply
MisterReen Premium
I am not a google expert but I think that Analytics works correct. Maybe siterubix saved your IP somehow. The last thing is to try via VPN (cyberghost) or icognito web browser window (in Chrome of Firefox), at least something that makes you appear to be logged in from another place. Then it should show that place and not Ashburn.

But at the end you simply can substract one user from Ashburn and for all the rest you can be sure that they are "real" people. Further, you can also setup a filter in google analytics that removes your personal IP from the statistics

The issue with your phone could be that you set it to be localized. Try to turn off the feature, so that your location cannot be tracked. I think google might be able to see if you are a mobile user or not
Reply
NINEK7 Premium
Thank you very much for your help!!!
Best regards,
Nina
Reply
Nrichards Premium
Good day have a guestion? with google analytics, the part that concerns me is if in the process off installing google analytics and i a miss and delete part of the information i am told that my site will be broken, makes me a bit uneasy, if this happens God forbids,is there a way to repair my site, or can i just avoid this by not installing. I don't want to make a mistake and pay a BIG BIG BIG price because i have worked so hard over the past months on my website thanks for your input.
Reply
upsgirl Premium
Installing Google Analytics is required.
You can't mess up anything...
Just follow the video and copy and paste your UA code.
You'll be fine!
Reply
Nrichards Premium
Good morning thanks for those encouraging words, all the best to you and have a good day.
Reply
upsgirl Premium
You're welcome!
Reply
JeffKent Premium
Trying to set this up. I don't have my tracking info / tracking code and I don't know where to find it.

Google Help says:

______________________________________
Find your tracking code, tracking ID, and property number
To find the tracking code, tracking ID, or property number in your Analytics account:

Sign in to your Analytics account.
Select the Admin tab.
Select an account from the dropdown in the ACCOUNT column.
Select a property from the dropdown in the PROPERTY column.
Under PROPERTY, click Tracking Info > Tracking Code. Click to expand this image and see where these options appear in the interface. Click to expand this image and see where the tracking code, tracking ID, and property number appear in your account.
______________________________________

I don't see a PROPERTY COLUMN so I can't get past that step to get my Tacking code
Reply
Deb425 Premium
Hi Jeff - I just did it. I went to "Admin" and then "Accounts" and then "Add New Account." After that, I was able to follow along. Hope this helps. I didn't see a property column either the first time, but now I see it. I just noticed that you posted this 6 days ago. Were you able to get it?
Reply
msnix Premium
If I already add this using SEO, do I still need to add I manually?
Reply
Juneyo Premium
No, you don’t. Unless, you still can’t verify your site using the AIO SEO method, you can try using this one.
Reply
msnix Premium
Thanks :)
Reply
Juneyo Premium
You're welcome =)
Reply
TheOldSilly Premium
No, not unless you are having trouble verifying your site, then the best method is manually
Reply
JennyMiller Premium
wow added and check I could see myself on my site.
Looks a little different to the training but everything is being upgraded and still pretty straight forward after watching this tutorial.
Reply
Doyonz Premium
I have to say that I absolutely love Google Analytics. This is so Awesome
Reply
clue Premium
I already have a google analytics account so I just added my website to the same one.
Reply
DaveBeech Premium
I've just done this. Google analytics looks very different now. It's very complex!
Reply
Ivine Premium
I enjoyed the lesson and completed the installation of analytics. The methodology used is out of date with the Google Analytics software.
Reply
newzion Premium
great tutorial Kyle...this is an easier way to add google analytics without depending on plug ins. I looked for the first <head> i then created a space in between the <head> and the next line....i think it was meta- but I created a space and inserted the analytics scripts and it worked fine. This was the easiest and quickest way I have ever installed google analytics without confusion from conflict with plug ins
Reply
AnthonyMLM Premium
Great tutorial Kyle thanks
Reply
WilsonJeremy Premium
I cannot find where to put the google analytics tracking code within my header.php file.

I've looked everywhere within the code itself and I do not see "<head>" anywhere.

What I do see is the "</header>" though.


So where do I insert the google tracking code?


I've attached a screenshot of the code for reference.

Thank you all in advance for your help.

All The Best,
Jeremy Wilson
Reply
mykc724 Premium
Nobody really uses that method anymore, that training video that you watched is a little out of date. The best way to do it is by grabbing your tracking code and inserting into the proper place on the setting of your all in one SEO plugin.
Reply
WilsonJeremy Premium
Ok....yeah, I've noticed that several lessons have issues with being outdated....any idea as to when they're going to update them?

Thank you for that info!

Wilson
Reply
WilsonJeremy Premium
Thanks Ken....yeah, I had already done this step which is why I was confused when I got to this lesson....but if doing the steps in your video is all that is necessary, then I'm already set.

Thanks again!

Wilson
Reply
pas1745 Premium
Jeremy, follow the link below by Ken-Pringle. I just did a Tutorial on adding the Tracking Code to Bing Webmaster Tool. The placement of the code will be the same. You say you saw </head>. This is the closing tag. Go up and you should see the opening tag, which is "<head>. Place your cursor after this and hit enter, this will give you a new line to paste the Tracking Code. I hope this helps.
Here is the link to the training Tutorial: Take care, Jeremy.
Reply
WilsonJeremy Premium
Yeah, there was /header...but no head tag. I had already submitted my site using the SEO plugin method, so all is good...I'm still confused as to why "head" is not in my code though.
Reply
pas1745 Premium
That is very strange. If you have a closing tag, there should be an opening tag. I am glad you got this done another way. Take care, Wilson.
Reply
WilsonJeremy Premium
Yeah, strange in deed! Must be my theme code or something. yeah, it's set... thanks bro!

Wilson
Reply
rfriedly Premium
do you have a gmail account
Reply
WilsonJeremy Premium
yes, I do have a Gmail account...why?
Reply
Igor69 Premium
Hello! I can not install it cause I can`t go beyond Terms and Conditions page. It does not give me an option to accept it, so I can`t get the code. Does anybody know how to get around this, or maybe there is a good substitute Google Analitycs?
Reply
Shawn Martin Premium
I use Histats on my sites for live numbers, and GA for more in depth data.
Did you try scrolling down to find the accept box?
Just a thought.

Histats is easy to install if you want to use it too.
Reply
Igor69 Premium
I will try it out! Thanks Shawn, I appreciate it!
Reply
JLMarker Premium
I added my google Analytic code, but when I ran the test, it did not show that I was on my site. Anyone know why?
Reply
rollyp Premium
The code takes a bit of time to kick in, It should function properly at this point. I am posting about 19 hours after your question. Sometimes it doesn't seem to show live results either, I don't know why.
Reply
JLMarker Premium
Thank you, but I just check it again and find that it is still empty. Can you go onto my website, let me know that you were there and then I will check again later today, or even tomorrow to see if it registered anything? JLMarkerCompany.com.
Thanks
Reply
Reahz Premium
I had the same problem but realised I forgot to press update file after I pasted it on my dashboard.
Reply
JLMarker Premium
Thx. I found that it took about two days to start seeing any kind of stats
Reply
dcart87 Premium
Hello, I am using Agency Pro - a studio press theme but I cannot find the 'header' section under the templates.

Where should I insert the tracking code?

Thanks.
Reply
Ken-Pringle Premium
Go to Appearance, scroll down to edit.
Click on it and follow this image
Reply
s44gould Premium
Here we go again. The page is different since this lesson was first installed. There is no dashboard tab like in the video. So once again I am stuck and frustrated. At least the videos should be current with the site.
Reply
Magieken Premium
This has happened to me too but you need to look for things as close as possible to what is in the video. I know it isn't easy when what we are shown is different to what we are seeing. Do you have a Google Analytics Account? If you do you will see up the top of you page Admin.
If you click on that it will show you the number you put into your site.
If all else fails Jay has a webinar that is much easier to follow. I will try and find the right one and let you know what it is. Good luck.
Reply
EKautz Premium
You're frustration is understood and shared by others. Keep in mind though that sites outside WA can be changed at anytime (just like you can change your site at any time) and keeping videos fresh is an ongoing process.

In the meantime, asking the community for help, or using the search bar at the top of the screen are the best methods to use.

ROCK ON!
E
Reply
juleswftb Premium
It is a little different but it is still pretty much the same if you go to admin-usermanagement-tracking info you will see the code
Reply