Hi everyone!

I’m hoping anyone can help me solve the issue I’m currently having in regards to the WA platform. For the past 5 days or so, I couldn’t access WA from my desktop, although I can from my iPad and phone. I have tried resetting my internet modem, clearing my cache, opening my firewall and restoring my PC’s internet setting.

After resetting my internet settings I am able to log into my WA account for a few minutes until it again becomes inaccessible. It’s really difficult to maximize the platform from tablet and phone. I can’t even attach a screenshot of what I’m trying to ask help for. 😊

Anyway, Google Chrome says, “The site can’t be reached, ERR_CONNECTION_RESET.” While Firefox says, “Secure Connection Failed. Please contact the website owners:”

Interestingly, I can’t also acces WA from all computers in my workplace. Isn’t that strange?

If I can’t solve this issue, I may have to cancel my WA membership.

Join the Discussion
Write something…
Recent messages
Eliz65 Premium
I’m interested in what you find out. I had the same problem on an ancient computer. It was on its last legs so I put it to rest so to speak.
I am grateful that I was able to buy a new one, as I agree it is really hard to get much done on a tablet.
I never tried site support. Just thought it was do to the age of my computer.
Hope they can help you.
Reply
Alysanna Premium
Site support suggested I try to access it using another network provider but haven’t done it yet.
Reply
Eliz65 Premium
Hmm ....?how old is your computer? Can you update your browser?
Reply
Alysanna Premium
I bought my desktop in 2014 so it’s about 5 years. I don’t think it’s my computer though because I can access all other websites.
Reply
Eliz65 Premium
It sounds like it might be a ‘trust’ issue for that particular site. Not sure though. Hopefully someone with some techie experience will be able to help you?
Reply
Eliz65 Premium
My only other suggestion is to try a different browser and then send a new site support request explaining what you did.
One last thought,
Can you try accessing on someone else’s computer or your phone?
Reply
Alysanna Premium
Yeah, I have no problem accessing it on my phones and tablets.
Reply
Eliz65 Premium
I suggest you try site support one more time and let them know what you tried.
Reply
Alysanna Premium
They suggested I tried it on another network. I’m guessing it’s my PC’s connection to the internet. Anyway, I’m planning to buy a new laptop but until then I’ll just have to focus on writing contents for my websites and publish them directly from my Dashboard instead of using site content.
Reply
ShuiHyen Premium
Contact sitesupport for assistance via your tablet. Tell them about your problem.
Reply
Alysanna Premium
Thanks, but I thought I just did. I posted this as a question to Site Support. I accessed the Submit Site Support Ticket.
Reply
merlynmac Premium
If you don't answer yes to the first option when contacting support, your message is sent to the WA community instead.
Reply
Alysanna Premium
Got it, thanks.
Reply
Top