Hi all, my google analytics seems to give odd readings or as of today not even giving me any reading

I have had this happening before, but just wonder of google analytics suppose to add your viewers instantly after they have been on your site?

Are my daily numbers to low to get decent readings?

It seems odd that all my visitors of yesterday have visited my website for 0 seconds while I I can see that affiliate links have been used though and I saw in real time a person visiting 4 pages. That seems hard in 0 second?

It seems odd too I have not any visitors at all for 10 hours while posted a and lot on social media in the last 24 hours.

Is my Analytics working correctly? Any insights on why this readings seems odd?

Thanks.

Jude

Join the Discussion
Write something…
Recent messages
LMH1968 Premium Plus
Pleased you have got it sorted
Reply
Jude81 Premium
Yes me too, I doubted my readings for quite some time now, and I am happy it makes more sense now.
Thanks for stopping by.
Jude
Reply
LMH1968 Premium Plus
I have 1 article which says it’s http. How did you change it Jude
Reply
Jude81 Premium
I had it filled out incorrect in google analytics. Go to admin<property and choose by the drop at the menu before your website name) https, click save.
Reply
LMH1968 Premium Plus
Thank you very much my friend
Reply
Aparna155 Premium
Mine shows no visitors at all.
:(
Reply
Jude81 Premium
Oh no, when did you set google analytics up?
Reply
StephenThiam Premium
My website analytics is not routine too. 1st August jump to 190 and yesterday 150 then back to the average level. No need to bother it, more important is click number in our affiliate program.
Reply
Jude81 Premium
Ok, thanks for your reply, I appreciate it.
Jude
Reply
Jude81 Premium
The issue is resolved now, by property in analytics there was HTTP instead of https filled out what apparently has given inaccurate reading. Very happy the issue is resolved.
Thanks for stopping by.
Jude
Reply
Top