I have an amazon associate code and then I found a check your links and it says that it failed and needed a http in front of it. So I went to my site and put my code at the end of my post and pages permalinks because it always says that my code is embedded into the items I show, so what am I doing wrong? Any ideas at all, Please?

Join the Discussion
Write something…
Recent messages
eagleeyes58 Premium
Sorry am no help at all
Reply
OldMCSEGuy Premium
I've had Amazon sites since 2008. I don't remember ever having an issue with my codes. I do remember a link check issue but it had nothing to do with mine cause it was something that I had done on an a store in correctly.
Reply
Ultimateless Premium
I have no idea if my links work and have no idea how to check them!
Reply
Compsol99 Premium
If you copy one of your links which includes your amazon affiliate id, and then log on to amazon.com associates, you can then click on tools and then link checker. Paste your link url and press "check link". It will tell you right away if your link is successful or not.
Hope this helps!
Shawn
Reply
Ultimateless Premium
Thanks Shawn, I'll give this a shot!
Reply
AndiTointon Premium
I have had my site for a good couple of months now, You just hope that somebody will perhaps buy something. Other people seem to be getting sales, I just felt a bit left out because I've worked really hard on my site and not a sausage. I have sent a message to Amazon to try and check that nothing is wrong.. Thanks for your speedy reply.
Andi.
Reply
MKearns Premium
There have been recent queries about this problem and the consensus that I have seen indicates that Amazon has aa vetting process that delays the code acceptance or that it is normal initial delay. Check in the next 24 hours and see if there is a better result.
Reply
Top