Hello guys, I'm currently using a free SEO analysis service of Onpage.org.

When I let them crawl my site CoachGom.com to take an analysis, they included in their error report...

WWW Resolve: Unfortunately the server does not redirect to this page, if someone enters the URL with a "www" at the beginning.

But then, opening it myself in the Internet browser bar using a www prefix, my site opens!

So, what is this site Onpage.org is saying?

What do they mean with their report?

Should I be worried with the report?

Can we trust them with their analysis?

I need an expert advice...

Anyone?

Join the Discussion
Write something…
Recent messages
MKearns Premium
Consider that the fact that the service is "free" allows complexities of this nature to fall through the cracks. Shopping around for another SEO detector may be advisable.
Reply
GomMagtibay Premium
Hi Mike, can you suggest of a good alternative?
Reply
MKearns Premium
Here is a good generic source Gomer. http://keywordtool.io/app-store
Reply
MarionBlack Premium
I just tried in an incognito window and it works with or without the www. You can't always trust online tools.
Reply
AffiliGuyUK Premium
Hi Gom,

I'm not exactly an expert but I'd suggest you look into DNS propagation. I usually contact the company where the domain is registered about these issues. It could simple be an A record needs adding but they will advise and propbably fix it for you. Although I have checked here https://www.whatsmydns.net/#A/coachgom.com and both variations appear to resolve ok.

From what I can see both versions of you site work for me. Plus if you type site:coachgom.com into google you will see that you have pages indexed for coachgom.com, whereas if you type in site:www.coachgom.com you will see none are indexed which could suggest a redirect is in place and working correctly. The rewrite is often a mod_rewrite in your .htaccess (in your sites root folder) which basically says direct all traffic to coachgom.com whether it has www. Before it or not.

Like I said I'm not an expert but hopefully this will point you in the right direction.

Cheers
Chris
Reply
GomMagtibay Premium
Thank you for that. And thanks for that extra effort checking with the details. I will try follow your suggestions and then will get back here to update you.
Reply
AffiliGuyUK Premium
No problem. I'd take on board the comments from other WA memebers too. Both variations seem to work for us all. So I personally wouldn't be too concerned.

Cheer
Chris
Reply
Profithog Premium
you need to go into webmaster tools /console and add your site as http://www.mydomain.com and verify it. that should solve the problem
Reply
GomMagtibay Premium
Thanks for responding.

Yeah, I already did that months ago. I wonder why they still include it in their report....
Reply
Profithog Premium
well, then that obviously isn't the solution is it?
Reply
Profithog Premium
ask someone in live chat
Reply
Top