I did a really stupid thing, I deleted tags from my website. I understand that was wrong, now what I need is some help. I have URLs that are returning a 404 error. I contacted Site Support, but I need some more help.

I ran a site search, site:myurl and found 7 links that have /tag/ in the URL. I clicked on these links and they are returning a 404 error. There are more URLs listed, 5 pages worth, but only 7 have the /tag/ in the link.

I don't know what they did, but Site Support sent me a message to delete the error message from Google Search Console, or rather "mark as fixed". I assumed that meant the error was fixed. I ran site search again, clicked on the link and the URL still shows a 404 error. I asked for clarification from Site Support. They told me to add the tag back.

So my questions are:

1) If I go through the 7 links that site search shows having /tag/ in the URL and I add the tag back to that post, will that fix my issue?

2) Is there another resolution? I have watched a video on 301 redirects, both using a plugin and adding some code to the .htaccess file, which I am a little afraid to do.

3) I do have a export file from Tools>Export, if adding the tags back works, can I get the tags from this export file?

4) Is this issue isolated to those 7 links since that is what Google currently has indexed for my site? Or can I expect more issues down the road? Now that the tags are gone, if Google crawls my site, there won't be any tags to index, so that is why I ask.

Thank you to anyone who can help.

Steve

Join the Discussion
Write something…
Recent messages
HennieSteyl Premium
Hi, Steve. If I understand you correctly, the issue is around the tags that are deleted. If that is the case then just add the tags back. That should fix the problem. Test the broken links that you see in the report. If it works, then go back to Search Console and mark the errors as fixed. I think that it will take Google some time to crawl your site again so don't expect immediate results.
Hope this helps.
Hennie
Reply
Melissa901 Premium
First off I am very sorry I have no idea how to do any of this. Second I really hope you find the correct answer you are looking for.
Third I am going to hold on to this cause I really could see my own self doing this.
Reply
Nkaujzeb Premium
Wow sorry to hear. Too new to help you with this but hopefully someone with more experience can help. I would like to know to...just in case it's my turn. ~.~
Reply
TopAchiever Premium
Steve, I would send a Private Message to Carson and wait for his reply if you are not successful here in your blog in receiving the reply you need.
Reply
skmorrow Premium
Thank you, I will do that.
Reply
Top