Something is wrong!

Last Update: May 02, 2018

So I’m sitting here about to catch a plane home and I thought I would google one of my sites horsesforsale.co.nz just to see how it looks in google and where my competitors are ranking and this is wwhat appeared:


This post is not on my site and has nothing to do with me?

How is this possible?

When I click on the link it takes me to my website and everything looks okay?

Have I been hacked?


Cheers Karen


Join the Discussion
Write something…
Recent messages
Melissa901 Premium
It looks that way to me. Sorry hope you get it taken care of.
Reply
kdforsman Premium
SiteSupport say no. I think it's a caching issue with my site.
Reply
Melissa901 Premium
Well it is good news that you haven't been hacked. But this is strange I wish I had a suggestion for you.
Reply
GoranBockman Premium
Looks like you've been hacked yes.
Reply
kdforsman Premium
SiteSupport say no. I think it's a caching issue with my site.
Reply
QAVAVO Premium
Its hacking, I hope you sort out things
Reply
kdforsman Premium
SiteSupport cannot see any breach of my site...
Reply
LouisaB Premium
Karen, I hope things have been sorted out for you.

I keep you lifted up on prayer.

Blessings.

Louisa B
Reply
kdforsman Premium
Thanks Louisa, it's now sorted - whew!
Reply
ElaineSmith1 Premium
Oops

Tried and True

Elaine
Reply
kdforsman Premium
Sorted now - whew!
Reply
dragonfly10 Premium
Dear Karen,
For some reason I was unable to open the page???????????
Reply
kdforsman Premium
It’s working now....
Reply
Flash4 Premium
That was nail biting stuff. See, even Google stuffs up.
Jae ♥
Reply
kdforsman Premium
Hi Jae
There is something weird with the site seo... so I still need to get to the bottom of this.
Cheers kaz
Reply
Flash4 Premium
Keep us informed Karen.
Jae ♥
Reply
kdforsman Premium
It appears to be all sorted now. I think it was a caching issue or something. Really odd, but there was nothing malicious. Whew!
Reply
elores Premium
I am not sure about this but i do hope you were not hacked. Hope you get an answer soon.
Reply
kdforsman Premium
Nope, it turned out to be a non event. Had me worried. especially when the blog post referred to someone by the name of hackenwerth (HACK-enwerth) LOL.
Reply
dbriley Premium
Wow! That would be a shocker. Hopefully someone knows the issues.
Reply
kdforsman Premium
BeauAndNik has given me a load of things to try below and I think I've got it all sorted now (huge sigh of relief that it wasn't something nasty!)
Reply
BeauAndNik Premium
Heya Kaz,

That is very weird. It looks like your meta description is all crazy. I'm not sure why this is doing this.

I done a search for answers and came across this site: https://kb.yoast.com/kb/my-meta-descriptions-arent-showing-up-in-the-search-result-pages/

Although I'm not sure this applies to your situation.

I also done a search using this site:horsesforsale.co.nz and uncovered another similar issue for this URL https://horsesforsale.co.nz/advert-location/canterbury

Have you got unique meta descriptions for all your pages/posts? Maybe change the home page meta slightly and get google to crawl it again and see if that makes a difference. This may take time for the search results to update. Just take note of the changes you make and the date/time.. This will give you an idea of time frames.

Perhaps Googles cache is out of date? Maybe try and fetch the home page again or use the submit-url link in google..

Let me know how you get on
Reply
kdforsman Premium
okay, that sounds great - I'll try all of those things! Really appreciate your advice!

BTW, I've checked all the posts etc, and there's nothing sinister lurking - nor is there anything weird in the meta seo descriptions of the site, so I think the caching is what it was.

Cheers, Karen
Reply
codevonish Premium
Are you sure you typed the URL correctly. Did you try more than once?
Reply
kdforsman Premium
Yes and yes. I think it's all sorted now. But had me quite worried for a bit!
Reply
codevonish Premium
Happy all is well.I can imagine the feeling.
Reply
kdforsman Premium
Thanks
Reply
Neb4412 Premium
Hi that's very strange maybe try contacting them thats all I could say hope you find the root to the problem take care chat soon.

Best regards
Nick
Reply
kdforsman Premium
Thanks Nick. I think it's sorted.
Reply
Neb4412 Premium
Ok that's cool have a good day speak soon.

Best.
Nick.
Reply
kdforsman Premium
Thanks!
Reply
HelenpDoyle Premium
Google can't find it so most likely are suggesting an alternative. When did you request indexing. I get this sometimes while indexing is occurring.
Reply
kdforsman Premium
agghhhhh that makes sense. It appears to be something like caching and relates to a kingsumo giveaway (not mine), but I have the kingsumo plugin on my site. Thanks very much for commenting - I'm feeling a bit less anxious now!
Reply
Happy2Learn Premium
Hmmm it is a mystery. At least the click bait takes you to your site.
Reply
kdforsman Premium
I know - it was very worrying!
Reply
KVanWormer Premium
That is odd!

kenny
Reply
kdforsman Premium
Hi Kenny, yes it was very odd, but seems to have resolved itself... I think it must have been a caching issue...? Cheers, Karen
Reply
MikeC69 Premium
Wow , that's weird ! Please let us know what you find here! Br=est of luck Karen !
Mike
Reply
kdforsman Premium
Thanks and yes I will.
Reply
accad Premium
Do you mean, the post is not yours?
Reply
kdforsman Premium
Nope. That post is definitely not mine!
Reply
accad Premium
Try to Google if there is another domain exactly as yours then Site Rubix lack the record details on domains in the world.
This is the issue, online entrepreneurs face today, the assurance that when you buy a domain name it should really be yours and no one else. If it is a duplicate the algorithm should know it, if we are fooled then we are being sold.
Reply
Steven-A Premium
wow. this might be a hack. did you notify site support? what did they say?
Reply
kdforsman Premium
I haven’t notified support yet but am going to do so, as soon as my flight lands!
Reply
Steven-A Premium
I get to your website when i put in the URL see image. I'm in New Hampshire, USA.
See if it is the same when you get home and your on your Internet connection. Maybe it's some strange wireless intercept.
Reply
Steven-A Premium
See image attached.
Reply
NicoAlpaca Premium
I copied your URL and I get to your site (horses for sale). Could be your browser on your cell phone acting up. Not sure. Cheers, Nicole
Reply
kdforsman Premium
I know. When I click on the google search result the correct page shows.... but why would a “win a trip to San Francisco” appear on the google search results when I’ve never written a post like this? It’s a mystery!
Reply