Analytics Showing Nothing

Last Update: June 04, 2019

Im rather confused.

I run a medical website and have had issues in the past with analytics. The code disappears from the website and we get no data.

Well I personally put that code back onto the webstie a few weeks ago and I still have no data. I have another program that monitors the website for traffic and this morning when I was looking at the analytics, losing heart in the whole process, I saw the other programme click up that there were 5 visitors on the website but the analytics said there was no one!!

I am losing the will to live with this analytics.. its telling me nothing and i am busting a gut to get as much traffic to the website as possible.

What can i do?

Join the Discussion
Write something…
Recent messages
lesabre Premium
Hi Helen, I wish I could help. I was following all the comments from
feigner.
Wish you the best,
Michael
Reply
Helen123 Premium
I e managed to dig my way through it! Finally, all day at it but got it sorted and discovered all my data has not been lost! I needed to remove the property and re apply.. when they moved from the old platform to the new one, something odd happened. So all ok but a shame it took all day, nit written the blog I had planned.
Reply
lesabre Premium
Hi Helen, so glad things worked out. Persistence in solving the issue paid off. Good for you and a great big thumbs up.
All the best,
Michael
Reply
LouiseBT Premium
Hi Helen
This happened to me not so long ago after I had changed the theme of my site. Perhaps you have changed your theme?
Site Support assisted me in getting things back on track.
Blessings
Louise
Reply
Helen123 Premium
I havent changed anything, I am always reluctant to change themes on these sorts of websites. I have a couple of planners that are attached directly by the guy who built it for me and a widget for booking online so I keep the info fresh but don't change the theme ! So I really cannot understand what has caused this to happen. I don't know what my keywords are doing, whether they are working or need tweaking.
Reply
LouiseBT Premium
Oh dear, sorry Helen, I was really hoping it would be an easy fix for you. Hope you have found the solution with the help of Phil and site support.
Blessings
Louise
Reply
feigner Premium
when you say you put the code back on the website - where are you putting it?
have you added your google analytics codes to the all in one seo plugin
is your property address exactly right in google analytics
have you tested it with realtime analytics.
there are loads of question, but no answers.
you know what you have done, but we are left guessing.
Sorry Helen.
phil
Reply
Helen123 Premium
Thanks Phil...

Yes I have done all that. I got Support to check this time that it was correct, it is added on SEO as well as the long html snippet added organically in the header.

Im not sure what else to do. Its clearly not working and Im getting no feedback as to what keywords are working and what aren't. Its frustrating to say the least. Im wondering if there is another website I can use that will offer the same as Analytics is so not working.
Reply
feigner Premium
might be confusing google to have it in there twice - bit like having two seo tools running .
i would remove it from the header.
have you verified you property again. can you?
have you gone into your account and under tracking info there is a send test traffic - just used it - it does work - takes awhile to appear - try it a couple of times.
keywords are another thing and another area - they are in google search console rather than google analytics. so start with the analytics and get the test traffic working - then move onto the search console.
there are a few alternatives but never used them.
https://www.computerworlduk.com/galleries/data/best-web-analytics-tools-alternatives-google-analytics-3628473/
don't know how they stack up against google
Reply
Helen123 Premium
thanks phil, the other tracker is on Tidio a chat plugin, so its a not a tracker as such with analytics but simply for me to chat to visitors..

Im on the console pathway....
Reply