Hello,
I recently purchased the yearly premium subscription. One of the perks of doing so, was getting a free domain. But when I went to set up the domain it is asking for either credit card information or to use WA credits. Neither of these options, is a free domain though.

Can someone please help me with this?
Thank you!

Join the Discussion
Write something…
Recent messages
MarionBlack Premium
This is not a technical issue with your website(s) so Site Support can't help. You need to send a private message to Kyle or Carson from their profile page. Use the grey search box at the top of the page to find them.
Reply
JeffWLewis Premium
Thank you for the response. I was able to get Site Support by following AbieAJ's advice and starting a free website.

Thank you!
Reply
paulash177 Premium
Going for premium, is not inclusive with the domain. That has to be purchase seperately
Reply
JeffWLewis Premium
Yes, but this was one of the perks for purchasing the yearly subscription. Thank you for the help!
:)
Reply
AbieAJ Premium
You have already asked this question, and fellow WA members answered by reaching out to support to resolve your issue.

If you could do so, would be appreciated. Alternatively, you can reach Kyle or Carson within.

Hope that was helpful, do let me know if you need anything else. Have a nice day.
Reply
JeffWLewis Premium
I apologize for the double post, the first one was through just asking a question link.

This one got posted here by submitting a ticket to support, lol.

Thank you!
Reply
Top