Hi guys

I have a few categories on my site and they are displayed in a side widget so people take select a category and it sorts the relevant posts according to the selection.

I added a new category but it is not showing int he widget and I am not sure why,

It is showing under categories and I can add the Category to my Main Menu - so it is there but not showing in the list of Categories displayed in the widget.


Any ideas? Did I somehow miss a step or forget to do something?

Thanks

Richard

Join the Discussion
Write something…
Recent messages
Ultimateless Premium
I seem to remember in dashboard you have to see it in your list of posts or edit it from there?
Reply
rwagener Premium
Hi
Loes solved the problem for me below.
Yes it has to be added to a post to show in the selection box. I created a sample post and added the new categories to it and there they were :).
Thanks for the help too.
Richard
Reply
Ultimateless Premium
The trouble with any software you have to think how the programmer thinks and where logically you can find the edits etc ....
Reply
rwagener Premium
Yep - and its not always how we think :). Anyway - all resolved.
Thanks
Richard
Reply
A-WEALTH Premium
Hi rwagener, thank you for posting this question. i had the same problem, and i am looking forward to the answer to your question so i can correct mine too.
Reply
rwagener Premium
Hi
Loes had the answer - see it above. It worked and is very simple.
Hope it solves yours too.
Richard
Reply
Loes Premium
WP has problems with apostrophes, did you perhaps use a comma into the text?
Reply
rwagener Premium
Hi Loes
Thanks for the response. I have since added 3 more categories and the same issue. There are no apostrohies or commas. The categories are:

Parent: Facilities
Children: Toilets
Playground
Drinking Water

I have deleted the Widget and added it back again but that has not helped.

Not sure what else to try. It seems to be showing in other places on the site where it should.

Richard
Reply
Loes Premium
Have you added posts to it, that can be the problem too, they only get visible when a post is attached
Reply
Loes Premium
When you want your categories displayed without posts in it, you have to edit a line in the header.php

https://wordpress.org/support/topic/categories-not-showing-up-2
Reply
rwagener Premium
Wow - that might be it. I'll go and try and get back to you.

Richard
Reply
rwagener Premium
Loes - you have nailed it! So obvious I guess but just didn't know. I have spent literally hours trying to solve this one. So simple and also so appreciated :). Thanks.

Richard
Reply
Loes Premium
Glad it worked, have been there too:))
Reply
rwagener Premium
Thanks again :)
Reply
FlorDiaz Premium
this is happening to me to, added a bunch of categories and they are not showing. I went ahead and purchased 3 goddaddy domains and I am going to transfer everything there. Sorry guys but the SiteRubix thing is not working for me and I am not getting any help from the community, it seems like I am not even part of WA. Disappointed :( I have been asking tons of questions and nobody seems to care, so sad
Reply
Top