Hi All!!

My site speed is slow according to https://developers.google.com/speed/pagespeed/insights/ and WA.

I have EWWW Image Optimizer installed.

It says these are the main reasons:
-Serve images in next-gen formats
-Eliminate render-blocking resources
-Remove unused CSS
-Reduce server response times (TTFB)

Does anyone have any idea how to fix this issue? Thank you!!!

Join the Discussion
Write something…
Recent messages
mtnmermaid Premium
Hi. I was having similar issues. Not with the speed of viewing my website on my desktop but mobile. My photos where not showing.

I came across this article which corrected the issue. I installed WP Super Cache and followed the settings recommended for the "Easy" and "Advanced" tabs. I then tested the cache and I am up and running.

https://azibyaqoob.com/wp-super-cache-vs-wp-fastest-cache-which-one-is-better-case-study/#:~:targetText=My website was now loading under 528 ms and it,milliseconds than WP Super Cache.


Hope this helps. Good luck.
Natalie
Reply
kprushiek Premium
Thank you!! I’ll definitely look into this later today!!
Reply
Aussiemuso Premium
I've read every comment here and there is some great advice. I have similar issues and have been trying different plugins.

I think it's a matter of trial and error depending on your theme.
Kraken makes my Generatepress speeds worse.

Lily 😊
Reply
ExpatMark Premium
Smush is every bit as good as Kracken.
Reply
Aussiemuso Premium
Definitely must try that Mark. Our modem crashed yesterday, so I can't get back on my website to try Smush until mid next week. 😫
Looks like I will be focused on mapping out my content list for 2020 this week and Christmas parties over the weekend.

Thanks
Lily 🥰
Reply
ExpatMark Premium
Don't forget Lazy Load. It is recommended by many smarter than me.
Reply
Aussiemuso Premium
Fortunately, I put Lazy Load on earlier in the week and it really helped Mark. Thanks for your advice.

Lily 😁🎶
Reply
RuthlynB Premium
I am wondering if you have too many plugins this could be a cause of slowing down your site, also you could ask in the need help, ask your question at the top of your page I get most of my questions answered there.
Reply
kprushiek Premium
I have very minimal plugins. Just what WA recommends, and then a couple extra. Thank you though!
Reply
ExpatMark Premium
Far starters EWWW is obsolete. That could be your only problem.
Delete it, back up your site and install Kracken image optimizer. Check your site speeds before doing this and then check them after installing Kracken
Let me know if that fixes your speeds.
Reply
kprushiek Premium
I will do this and let you know! How come WA automatically installs EWWW then? just curious!
Reply
kprushiek Premium
Tried this and the site speed was the same with both plugins =/
Reply
ExpatMark Premium
That is old training. I would have thought Site Support would have installed Kracken for you since your site is so new. They did it to my newest site as well as many others.

I am using Smush on one of my sites because Kracken had not been updated in so long, and like it as much as Kracken.

I asked Jay about it and he said "some plugins do not need to be updated as often". Jay recommends Kracken, so that is what I would install if I were you.
Reply
ExpatMark Premium
Have you got the Lazy Load plugin installed? It is supposed to help with site speed.
Reply
kprushiek Premium
Thanks for all that info!! I will change it all!
Reply
AffMktgRt Premium
Katy, I am sure some will provide you with the proper answer, In the event that the issue persists, there are some tools out there, fairly affordable. Let me know.

Blessings!
Reply
kprushiek Premium
Thank you!
Reply
Top