I tested my website for speed on Google Developers site and the follow message returned, I have no idea what this means, is there any gurus out there who can Help? Cheers Kev

Should Fix:
Eliminate render-blocking JavaScript and CSS in above-the-fold content
Your page has 17 blocking script resources and 13 blocking CSS resources. This causes a delay in rendering your page.
None of the above-the-fold content on your page could be rendered without waiting for the following resources to load. Try to defer or asynchronously load blocking resources, or inline the critical portions of those resources directly in the HTML.
Remove render-blocking JavaScript:

Join the Discussion
Write something…
Recent messages
WaynePro Premium
Have no clue about any of this yet, but I am glad you offered up the question and as usual, great responses from the WA family.

Wayne
Reply
With-Kev Premium
Yes Wayne, WA is awesome. Cheers Kev
Reply
MKearns Premium
Reply
With-Kev Premium
Thanks Mike. Cheers Kev
Reply
dorina62 Premium
MKearns, I remember I tried this plugin before and it did not work for me! I tried it again, my mobile speed decreased from 77 to 61 in https://developers.google.com/speed/pagespeed/insights/
so I deactivated! I'm not sure how to do the proper settings for this plugin!
Reply
With-Kev Premium
Ispeed is good with what I have done, enough to do now. Don't need problems now. Thanks for your help. Cheers Kev
Reply
dorina62 Premium
You welcome! I'm glad you improved it!
Reply
annarella Premium
I too am having this issue. I have tried the autoptimize plugin and the plugin that PJ recommended in his training (WP Super Minify) and neither are resolving the issue. They may work for your particular theme though.

Wish I could be of more help!

Anna
Reply
With-Kev Premium
Thanks Anna , I will try and let you know. Cheers Kev
Reply
With-Kev Premium
Hi Anna, I reduced the image size and improved the download time heaps. Not worrying about this issue. Cheers kev
Reply
annarella Premium
That's awesome - thanks Kev! Enjoy the rest of your day! :-)
Reply
With-Kev Premium
You are welcome. Cheers kev
Reply
jimk43 Premium
I got the same message and when I sought help from WA member PJ he stated 'Getting those items resolved is going to break things. They can't be tweaking without some major coding going on'.

Jim
Reply
With-Kev Premium
Thanks Jim, maybe I need to move onto the next item. Cheers Kev
Reply
GeoffGS Premium
Even the plugin suggested by MKearns says it's for advanced wordpress users only, and optimization professionals.
Reply
With-Kev Premium
Hmmm so I should be careful. What could happen if I use it? Cheers Kev
Reply
GeoffGS Premium
I'm not sure. Break your site?
Reply
jimk43 Premium
Not my words!

Jim
Reply
With-Kev Premium
Hahaha , something I definitely don't need. Thanks for your help. Cheers Kev
Reply
With-Kev Premium
Yeah Jim. I have done enough. Thanks for you comments. Cheers Kev
Reply
dorina62 Premium
A lot of these errors comes from the theme itself, I have a test site and I tested something and these errors were there!
Reply
With-Kev Premium
It is only on the mobile test, could it be a plugin? Cheers Kev
Reply
dorina62 Premium
You must rewrite some, and at least me, I'm not advanced to do this! I leave it like it is, I had mobile 76/77 speed and the site loads pretty quick on mobile.
Reply
With-Kev Premium
Fair enough I have load speed of 67. Cheers Kev
Reply
GeoffGS Premium
I'd look into image compression to speed your site up.
Reply
CMohring Premium
I have a lot of those errors on all of my sites also but visiting my sites on desktop, laptop or mobile devices and they all seem to load pretty quickly. Quickly enough for me that I don't think the user experience is harmed.
Reply
With-Kev Premium
I have resized the images on my site and reduced the load time. I will stop at that. Thanks for your help. Cheers Kev
Reply
dorina62 Premium
You must compress them, too! Try EWWW plugin to optimize your images!
Reply
Top