Hey guys,

I'm using Thrive Leads plugin for popups and lead generation. Everything was working fine until yesterday's update. Ever since I have updated the plugin to the newest version, my popups are not working at all.

Has anyone else experienced the same problem? If so, what have you done to fix this?

I tried everything. I cleared cache, deactivated and reactivated the plugin, deleted and installed it all over again, contacted Thrive Support but they are ignoring my problem...

Thrive Themes Support was no help at all...

Join the Discussion
Write something…
Recent messages
Triblu Premium
Hey Ivan,

The only thing you can do is to sign into your Thrive account and put in a ticket. After their deserting their themes and support of those paid for themes, I no longer trust Thrive... but I do know they will support their page builder.

Hope you find this helpful.
Reply
ParthaB Premium
Hey Ivan,

Have you got WA SiteSpeed turned on?

If so, turn it off, then reinstall the plugin and see if that works.

I believe Thrive themes and the leads plugin have some form of caching attached to them.

And thus can cause a conflict with WA's SiteSpeed caching.

This was probably not an issue initially, but further updates to themes and plugins can cause this conflict.

If it does work after doing that, check page/post speeds in about 24 hours.

If all is fine, then that's good.

If speed is down, you may have to make a choice between using thrive's latest updates and SiteSpeed.

Or of course, you could install a premium caching plugin to replace SiteSpeed (I use WP Rocket and I believe Abie, who's replied, does as well).

Let me know if that works.

Partha
Reply
AbieAJ Premium Plus
Thank you, Partha. Informative and as usual.

That could possibly work or even setting it up at Accelerated vs Extreme. What do you think?
Reply
ParthaB Premium
I think it depends on the update.

But I do know that the thrive leads plugin has a "cache friendly mode" .

So, when enabled the plugin should then be compatible with other caching plugins.

Whether that "cache friendliness" stretches to WA's SiteSpeed, unfortunately I don't know.

For me, all the sites that I have WP Rocket installed on I have WA's SiteSpeed completely turned off.

Partha
Reply
IvanBroz Premium
Thanks for your suggestions, mate. I’ll try that as well.
Reply
jghwebbrand Premium
Can you get the old version and reload it? We have had to do that with other plugins sometimes until another version is provided..
Reply
IvanBroz Premium
I have tried to do so via the WP Rollback plugin. But Thrive Leads is not compatible with it. Most of the plugins are, but this one isn't.

My last resort is returning my site to the last backup version before the plugin was updated. Would that work?
Reply
jghwebbrand Premium
If you don't have other updates since the last backup it should work.
Reply
IvanBroz Premium
I haven’t had any updates since yesterday. I’ll see. Thanks for your help!
Reply
AbieAJ Premium Plus
Hi

I'd contact their support again for assistance. May be they are relying on another upcoming update to fix the problem rolling out.

This happens with software updates, as in fixing bugs.
Reply
IvanBroz Premium
They have ignored my last five messages...

Maybe they are working on fixing bugs. Thanks for your help.
Reply
AbieAJ Premium Plus
So very welcome.

Hope they roll out an update soon.
Reply
Top