Wordpress Has Gone Nuts?

Last Update: February 03, 2018

I have just spent 2 hours writing a blog post. First, it was written in a doc and copy/pasted into the WP editor. I have been doing this for years. Today, every time I save the post, the fonts change in a few paragraphs here and there.

Over and over, even though I go back and copy paste those sections.

I updated the WP version. Restarted the computer. Trashed the post and started again. For a few minutes all went well. Then on the third Save it happened again.

Anyone else ever see this behaviour?

Update 02/02/18: Thanks to all below! My main goal in writing was to have a larger font. Only yesterday did my copy/paste from a doc start losing format in the WP editor. Not just the font, but sentence structure as well.

I have solved the font size issue with Marion Black's video cited below.

It is not a theme issue.

Today I will clear format in my doc and paste it into the Site Content editor. Then when it is in WP we'll see what happens with the formatting which I will have to do finish manually at that point, because there is no bullet option.

My next post I will write in the Site Content editor. See how that goes.

Does anyone know if the images in the Site Content Editor are compressed and sized well?

45 minutes later: A complete waste of time. I cleared format in my doc, copy/pasted into Site Content Editor, manually formatted it again, then copy/pasted into WP editor. The formatting went all over the place and even as I fixed it, it kept losing the formatting.

I have just spent 8 hours on one blog post. And it's just a big mess. None of this was going on day before yesterday, whether I used Libre Office or Word. Wt? Now off to work, I'll catch up later.

The trouble with writing from the get-go into the Site Content Editor is there are no line spacing options, neither are there any in the WP editor. So there will always be time spent manually formatting. Images made in Canva have to be loaded into the WP editor anyway - so I hope I can get back to doing what I was doing 2 days ago, which was quick and effective.

Later peeps!


Join the Discussion
Write something…
Recent messages
elores Premium
I have not used Site Content for my posts for a while.
I use word press editor and I have no problem with it.
I hope everything works out for you soon.
Reply
DianneBee Premium
Update - I have been clicking through my blog posts just now and suddenly came across one where there are two font sizes showing intermittently down the content.
Not the one I was working on yesterday, but a post that has looked just fine for a year.
What is up with that?
Reply
DEversley Premium
Have you had any recent them updates?
I suggest you stop pasting from Word an use the WP editor.
Go back to your posts and remove all of that extra HTML caused by pasting.

If you want more editing control over your text in WP, then use Tiny MCE Advanced https://wordpress.org/plugins/tinymce-advanced/

It will allow you to do all of the formatting you want right within WP

David
Reply
DianneBee Premium
Thank you!
Reply
LouisaB Premium
Hello Diane, I just recently published a post, and shared it with social media. Haven't experienced anything strange yet.
Reply
BillandSue Premium
Hi Diane,
I used the Site Content Editor yesterday on a post to my website. Everything went well so it seems. After publishing, I went into WP Editor, took a view through "View Post" like a visitor would see it. It was a mess. I am not sure where the issue is, but it was correctable.

I am not using Site Content right now until experience with my WPs theme editor. Hope you have better success.

Bill
Reply
DianneBee Premium
I hope you do too! This is very time consuming. The mystery to me is what happened between a few days ago and now? Strange!
Reply
GoranBockman Premium
OMG. That must have frustrated you to the point of tears!
Reply
DianneBee Premium
It did! I finally got the post published with lots of manual formatting. I hope this is the end of these complications!
Reply
GoranBockman Premium
I hope so!
Reply
Armlemt Premium
To answer your question on images in SiteContent, they are compressed and optimized.
Reply
DianneBee Premium
Thank you!
Reply
Armlemt Premium
You're welcome!
Reply
Memorylaneuk Premium
I always use site content editor and never have any problems. Why don't you copy and paste into there and then publish to Wordpress from there.
With Grace and Gratitude
Karen
Reply
DianneBee Premium
I hadn't been using that because of the font issue. Now Marion Black has shown me with her video how to change the font side wide which is all I wanted. But what concerns me is I never had issues losing the format before, which is happening in the WP editor, suddenly. But I will try the site content editor today.
Reply
GBridgart Premium
Same thoughts as laurenjean
Reply
laurenjean Premium
I had issues transferring Word doc content to Wordpress too, Dianne. I used to have copy and paste all content to Libre Office Writer unformatted and then reformat manually. It was such a mission.
Then I switched to Site Content. Problem solved. I can transfer from Word or Google docs or anywhere and its so much easier to format for WP.
Reply
DianneBee Premium
That's good to know. Now that I've solved the font issue thanks to Marion Black, I will try the Site Content editor.
Reply
elores Premium
I only use "Post" and "Add New" on my website and it works fine.
Reply
DNicholas Premium
Since I started using site content I haven't had any issues.

Don
Reply
Wayne66 Premium
I've been using the "Sit Content Editor" since late last year and haven't had any issues transferring to my WordPress.

Probably not much help. Do you or have you used "Sit Content Editor"? If not, maybe you could try it and see what happens.

Moving Forward
Wayne
Reply
DianneBee Premium
I haven't been using it because of the no font choice. Also no bullet option.
Reply
Wayne66 Premium
I change fonts after the transfer to Word. I haven't had any issues......so far.

Do you think it might be the theme? Just putting that out there as a possibility.

I hope you are able to get it figured out.

Wayne
Reply
DianneBee Premium
I was able to change the font size site wide the way Marion Black recommended. Whew! I'm not getting perfect formatting though and I will try again to copy/paste it into Site Content and see if that fixes the loss of format issue. Cheers!
Reply
DianneBee Premium
Another question Wayne - " change fonts after the transfer to Word" - transfer to Word from where? Or did you mean WP? How do you change fonts there?
Reply
Wayne66 Premium
Hopefully, I can explain this adequately.

When you are in WP admin., from the dashboard column click Posts and choose "Edit" on one of your posts.

When your post content comes up, above that you will see, I hope, two or three rows of icons. On the bottom row to the left, there should be two boxes. The left one is for choosing the font and the one next to it is for choosing the font size.

I hope this helps and you are able to do what you want. As for formatting, I'm not sure how to fix that. All I can suggest is, that you send support a question. They are pretty good at fixing the technical stuff.

I'm also glad Marion was able to help you out. She's pretty amazing when it comes to knowing what to do with computers.

To your success and, Moving Forward,
Wayne
Reply
DianneBee Premium
OK so I do not ever see those choices in the WP editor so perhaps that is a theme issue. Thanks Wayne.
Reply
ElaineSmith1 Premium
Did that to me every time I would try to write my blog since January. So I have just been writing in the blog area. I wanted to take advantage of spell check but guess not.

Tried and true

Elaine
Reply
MarionBlack Premium
Right-click and select 'Paste as plain text' and add your formatting and images later.
Reply
DianneBee Premium
Thanks Marion. I've been writing in a Libre Office doc with font 18. I've copy/pasted into about 30 posts this way with no problem. Today - it just won't keep the font all the way through, yet does in some paragraphs. And this changes every time I Save Draft.
Reply
DianneBee Premium
I don't think I have the confidence to customize a theme. That's what you mean, right?
But I'm looking at it - thanks!
Reply
DianneBee Premium
I did it. Nothing changed - but this is even weirder - and maybe I'll just come back to this tomorrow - when I click to the Text version of the draft - it is still in Visual. I kid you not. So I am going to shut the computer down and return in the morning. Thank you so much!
Reply
MarionBlack Premium
Perhaps you just need to logout and login again.
Reply
DianneBee Premium
I will do that. Thanks for your patience!
Reply
DianneBee Premium
Success! I changed computers. I use Ubuntu but switched to Windows and started the post anew. I also followed your video and again pasted in the code from it, with the number size I wanted. And it has worked!
There must be a glitch with Ubuntu right now that I hope some updates will fix. Thanks for your help!
Reply
MKearns Premium
So far theme possibility rules!
Reply
DianneBee Premium
I checked this by pasting the same post into different sites - 2 are the same theme and the third is different. But the same phenomenon occurred.
Reply
Swangirl Premium
I have not had this happen since I type directly in Wordpress. I do not copy in text. I know this doesn't help you but it works fine for me!

I know people want to have a copy saved elsewhere but I would suggest you could copy and paste into word at the end after you create it in Wordpress.

Jessica
Reply
DianneBee Premium
Problem is I like a much bigger font. I started using a bigger font a while ago and I think the site looks so much better. And I just checked (I haven't posted since November) and yes it worked then.
Thanks!
Reply
DEversley Premium
Use this to paste from Word
Reply
DianneBee Premium
Thank you!

...OK so that pasted in with the whole thing in a different font. This works on other blogs so maybe it's the theme.
Reply
DEversley Premium
Don't copy text from Word. When you do, a lot of extra HTML is added to WP. Copy in plaintext or use SiteContent.

David
Reply
DianneBee Premium
Ah-ha! I should have cleared formatting before I started writing. Those "little things"!....

Nope that didn't work either. I started again and saved. Then put the images in and fonts changed.
Reply
DEversley Premium
Try clearing your browsing data (cache)
Ctrl + Shift+Del
David
Reply
DianneBee Premium
Thanks - did. Still same problem. Maybe I'll clear all history, restart and go from the beginning.
Reply
Shweta10mg Premium
I relate with the extreme differences in word and Wordpress but not with the crashing phenomenon.
Reply
Top