The Print Screen above shows my statistics on SiteContent:

Articles published = 5

Indexed in Google = 0

Please, can someone help me and explain why my articles are not getting indexed? The first to be published was a month ago.

I have been using a Keword Tool. I will be grateful if someone pointed me in the direction of improving my article ranking.

Many thanks.


Join the Discussion
Write something…
Recent messages
PaulChatwin Premium
The only way to be sure is to set up a google search console account in Webmaster tools.
You can request Google to visit individual posts and start the ranking process.
I do this each time I post content.

I think Jay has a video on it somewhere.

Google Webmasters – Support, Learn, Connect & Search Console ...
https://www.google.com/webmasters/
Reply
ZEGU Premium
Hi, Paul, I will definitely look into this. Thanks so much for sparing time to respond. All the best in your projects.
Reply
GiuliaB Premium
Yep, I noticed as well. But I think Mike Kearns may be right there :)

Giulia
Reply
ZEGU Premium
Thanks so much for taking your time to reply. All the best.
Reply
ThomasPaul Premium
My articles don't show up as being indexed by Google either, but I know some of them have been indexed. Probably a bug like other people have mentioned.
Reply
ZEGU Premium
Thanks, Paul, that's reassuring.
Reply
MKearns Premium
I haven't been using this yet. I don't think it has all the beta testing bugs yet worked out!
Reply
ZEGU Premium
It's a relief to hear that. Thanks so much for your response.
Reply
bethcharron Premium
I can't help but it wiil be interesting to see the answers Thanks for asking
Reply
ZEGU Premium
Yes, you are absolutely right. With Google, you never know. Thank you for your response.
Reply
Top