I have prepared a new post in Word and tried to copy it to my site it won't copy the whole article, just snipets. Help?

Join the Discussion
Write something…
Recent messages
Triblu Premium
Hey Earl,

If you're using the Block Editor that MAY be the reason. Copying and pasting from Word (using Windows10) into the Visual and/or Text Editor (when using the Classic Editor plugin) still works fine for me.

I even use Word and copy only paragraphs of text when copying from Word into the Block Editor as some of the newest sites that I have created, I made sure to use the Block Editor.

Hope you find this helpful.
Reply
ELangley1 Premium
Hello, Trish. I deleted Block Editor and am using Classic. I did make the move from AIO SEO to Rank Math. I just wonder if that could be the problem. Anyway, right now I am kinda hung up. I seem to remember that someone else recently was having this problem but I don't remember who. It may be that I will have to convert my post to some other format. Thanks for your response.
Reply
ELangley1 Premium
Hey, Trish. I had downloaded the WP Font plugin. I deactivated it, and now it's working. Thanks again for your help.
Reply
Triblu Premium
Personally, I STICK to Kyle's suggestion (and MANY other SEO pros) and continue using All In One SEO pack plugin.

Rank Math DOES create a LOT of conflict with many themes and other plugins. Maybe in time they will perfect this plugin.

Sorry to learn that you had to install yet ANOTHER plugin just so you can copy & paste from Word.

The reason I'm forcing myself to use the Block Editor in NEW sites is that one of those who LOVE the Block Editor (I think it may have been Jay) claimed that this editor will be FORCED upon all users in the near future.

Am praying that won't happen... but you never know for sure.
Reply
ELangley1 Premium
Thanks, Trish, for the follow-up response. Have a great weekend.
Reply
YvonneBray Premium
Thanks for that question. I write in word all the time and copy to Wordpress block.
Reply
PhoenixFlame Premium
However, does it make it happen that you can change the Font in Word and upon pasting into Blog Post article, does it change to that Fonts look or not afterwards?
Reply
YvonneBray Premium
To be honest with you I haven’t even thought about changing fonts only italics or bold. Sorry.
Reply
ELangley1 Premium
Thanks, Yvonne. I am still using Classic Editor, but my issue has now been resolved.
Reply
MarionBlack Premium
Use the block editor instead of the Classic Editor plugin and it *will* work.
Reply
PhoenixFlame Premium
Good suggestion, never really thought of it that way before. How is you doing Mrs. Maid Marion from Robin Hood?
Reply
MarionBlack Premium
I'm doing fine, thanks. I hope you are well too, Angelina.
Reply
PhoenixFlame Premium
I am doing better if it were not for sinus congestion headaches and migraines each morning from dust being breathed in.
Reply
MarionBlack Premium
Sorry, I have to say it (LOL) smoke gets in your eyes, PhoenixFlame.

Seriously, I understand. It's spring here in Oz and that's hayfever season.
Reply
ELangley1 Premium
Thanks, Marion. I'm back up and running.
Reply
AbieAJ Premium
I like Angelina's suggestion. That's in windows.

If in Mac, that would be Command + C to copy, however need selecting your text and Command + V to paste.
Reply
PhoenixFlame Premium
(^_^)
Reply
AbieAJ Premium
Mine is working great.

Save your work, close document, reopen and try again. Hope you get it resolved.
Reply
ELangley1 Premium
Hello, Abie. Thanks for your response. I'm back up and running.
Reply
AbieAJ Premium
Awesome, so happy for you.
Reply
Top