I have had site speed issues for some time now and have tried various things to improve this issue.

  1. Installed smush for lazy load. deleted now as I learned I shouldn't use it when I have Kraken?
  2. Minimize my plugins, just deleted a heap and still not any better
  3. Optimize all my images with pix/l
  4. Changed to general press, didnt reslove the issue and dont use it anymore now.

My website speed is a shocking 29 red coloured number. When I look in site health especially the mobile sites are bad with various articles.

I dont understand why some articles having a worser site speed than others. EG, even my index page had a bad site speed and there is hardly any content and no image on this page.

I am not sure anymore where to start to make my site speed better anymore as nothing seem to work.

I have only around a total of 10 pages and 30 articles too, I cant imagine how bad it is going to be when I have 80 articles on my site.

Any suggestions will be appreciated.

Jude

Join the Discussion
Write something…
Recent messages
1Rudy1 Premium
Chrystopher provided an answer t one of my questions re the use of kraken now that the most recent updated of wordpress now includes lazy-load. If you updated and are using wp5.5, check your plugins to see if you have more than one lazy-load plugin.
As Triblu said, check your theme, not every author updates their theme and it may no longer be up to date with the current wordpress.

When you conduct a speed test,, there should be a resulting list of things to check to help increase the speed..
When I did a check I found that my desktop version was slow, yet my mobile was very fast,, like high 90s fast...go figure.
Reply
Jude81 Premium
Thanks Rudy, I am trying to fix the issue, i have activated the plugin asset cleanup but it is not as easy as the other plugins I have used on my site.
I have to go studying to use the plug in correctly.
Thanks for stopping by, I appreciate it.
Jude
Reply
1Rudy1 Premium
You're welcome...you'll figure it out!
Reply
Jude81 Premium
Not so sure, started to follow some tutorials but I ended up deleting the clean asset plugin. The plugin is way to complex for me to use. Not sure what I am going to do next
Reply
1Rudy1 Premium
Keep things simple. Go back to Chrystopher's reply. He offered some solutions for you....
Reply
Jude81 Premium
i did but didnt hear him back yet. I feel like throwing my computer at the moment. I spend all day trying to understand this plug ins no reslutls Feel frustrated. brrrr
Reply
Triblu Premium
Hey Jude,

If this might be of value to you, I recently discovered my once upon a time favoured theme is now no longer being tended to by the developer. They have literally walked away from their responsibility to their paying customers.

However... Tom Usborne to the rescue with a light-weight theme call Generate Press. BUT... DO buy that theme so that you will have EVERYTHING that is included in his premium version. It is sooooo worth the $49 US funds he requests.

Nearly EVERYTHING I needed to know was EASILY Google searched and found instructions for. And those few issues that I could not find solutions to, his support staff are amazing!

My mobile site speeds went from as low as 23 using the previous theme to upwards of 85-90 using Generate Press.

Will send you the URL to my post, raving about this theme, as it needs more plugins... BUT... it is faster than the previously optimized theme that I had paid $69 US funds for as well as $40 US funds for THEIR support.

Hope you find this helpful.
Reply
Jude81 Premium
Thanks Triblu, I will look I to this. I have downloaded asset clean up for now but didn't configure it yet as I Am unsure Of using it.
I also downloaded magnify to try this out and bulk optimising is very slow compared to slush, so I had to find out today if it was successful.
I check your message, thanks for sharing, I appreciate it.
Jude
Reply
Triblu Premium
No problem Jude.

Like you, I was slow to try Generate Press after listening to the pros.

And now, I am soooo thankful that my MMO (make money online) site is FINALLY back to what it was previous to the traffic I had in back in March.
Reply
Eliteme Premium
Thanks for Jude's post, I also had the same question and seemingly here are some very good replies to answer some of my concerns too. Thank you very much.
Reply
Jude81 Premium
You are very welcome, I hope we get it both sorted.
All the best.
Jude
Reply
laparra1 Premium
Good afternoon Jude,

Perhaps you remember that I have also been struggling with SiteSpeed for some years.
At the moment I am facelifting all my posts from the beginning and re-downloading pictures in a lighter version, etc.
Some days ago I came across a post mentioning SiteSpeed problems. Marion came up with a great site checker tool.
Lo-and-behold, my sites are A99, loading under 1 minute.
You can imagine that SiteSpeed is gone from my worry list, but I will continue pepping up my old posts. Greetings from the south of Spain,

Taetske
Reply
Jude81 Premium
Yes, I do remember you had site speed issues too. I will check out the training, thanks for sharing, I appreciate it.
Have a great day.
Jude
Reply
laparra1 Premium
Jude, it is not a training. It is a tool to check your website with. The results were significantly better than with the previous tools I used. I will not worry about SiteSpeed anymore, ever.
Marion came up with that tool, brilliant.

All the best, Taetske
Reply
Jude81 Premium
Aha, ok thanks that is great. Thanks for sharing.
Jude
Reply
Mark K Premium
Looks to me like there may be a plugin causing the issue. Have you tried disabling all your plugins (except SEO) to see if it helps?

If it does, enable them one by one checking your speeds to see which one it is.

It also looks like you have large images or a lot of them on each page, even though they are being optimized.
Reply
Jude81 Premium
Ok thanks, I try that. I appreciate your help.
Have a great day.
Jude
Reply
Jude81 Premium
I have unistalled all my plugins except seo and my site speed is stil 3.2 shocking.
So frustrating.
Reply
Mark K Premium
3.2? What theme are you using!?
Reply
Jude81 Premium
times news. I just did a training which was great and the plugin was much easier and my site is much quicker now but my site is gone...help
#edit, I think it is fixed now, not sure what happened
Reply
Mark K Premium
Looking at your site, you have a lot going on. Ads, email opt ins, plugins, news ticker etc. You have 81 requests on your home page alone.

I'm not sure you will be able to do anything to the speeds, except utilize caching.

Try a caching plugin like W3 Total Cache or WP Super Cache. There are loads out there, each doing similar things.
Reply
Jude81 Premium
Ok, thank you mark. The minify plugin helped with the site speed but coursed errors on my site.
I deactivated it, and the error seems resolved.
I will try the w3 total cache and see how that goes maybe.
Site support suggested contacting the theme I am using for the I used java slowing me down.
Hopefully, I get it sorted soon.
Thank you for your support

Jude
Reply
Top