When I copy my amazon affiliate link and paste it to my page, I update and then click on the link to check if it's working, but it takes me to an Area 404. Why?

This is my first link that I'm placing, so a bit confused. The HTML code from Amazon is so long, do I have to highlight it all before pasting to my page?

Join the Discussion
Write something…
Recent messages
SamTea Premium
Check the Dom's tutorial about amazon.
He has it explained, I think.
Reply
Blessings44 Premium
Thanks Sam. Are checking out Tommy and Labman's videos listed below. Will check out Dom's too. Can never learn too much. Lydia.
Reply
armah elibe Premium
You did not copy the given code properly I guess, if you can make sure you copy the entire link and past on your page , but not before clicking on TEXT/HTML at the top left hand corner of the space for your post. Click visual beside text/html after pasting the link. Then update, everything will come out nicely as expected when you view the page you just updated. Good luck.
Reply
Blessings44 Premium
Hi Armah, thanks so much for the info! Seems like there's an art to everything! Lydia.
Reply
Gordi Premium
That's right Armah. It took me a while to get a handle on links. You don't always have to copy the entire link, but you have to know what is relevant and what isn't.
Reply
tommydillard Premium
Here check out my video maybe it will help you.
http://goo.gl/YdmTXl
Reply
Blessings44 Premium
Thanks a stack Tommy! You've been a lifesaver of late.
Reply
Glovett Premium
I had a similar problem, you actually dont need the entire amazon affiliate link, just the part in between the quotes.

Check out this training by labman and it will explain exactly how to put amazon links onto your site!

https://my.wealthyaffiliate.com/training/amazon-links-adding-and-editing-your-amazon-links

If you're still having problems pm me and I can try to help you further! Good Luck!
-Gav
Reply
Blessings44 Premium
Thanks Gav, will check it out! It's amazing how quick you guys are to respond to questions. That's why I love WA so much!

Will keep you posted.

Lydia.
Reply
Glovett Premium
Anytime Lydia, that's definitely the best thing about WA. It doesn't matter what your problem is chances are someone else has already gone through it and found the answer!

Also don't forget you've got live chat and the search bar (at the top under tutorials) that way you won't have to wait for someone to respond.

-Gav
Reply
Check the link itself. There might be a problem with a space in it where it shouldn't be, or it's misspelled. Do you have all of the link's code there? It's probably how you've formed the link, or something related to this.

That's all I can think of why you would be winding up at a 404 page. This means you are reaching a page that doesn't exist.
Reply
Blessings44 Premium
I have highlighted and copied the link direct, so it can't be a spelling or space issue.
Reply
Top