Is This A WA Wide Issue Or A WP Theme Issue?

Last Update: August 10, 2018

After inserting the Amazon affiliate links to my content on the WPDashboard back office, the words that are linked are highlighted. That's great! Fantastic!

And when I scroll over the highlighted words it routes to the Amazon linkshowing the product and other relevant product information. Again that's beautiful!

These same highlighted words, however are NOT highlighted on the published copy that the readers/prospective customers see...unless the readers scroll over the specific content containing the links. (In fact, the links are otherwise incognito, just nicely tucked away and baked unto the rest of the post!)

I'm not interested in creating word puzzles for customers to be running around chasing for their product into the next brick and mortar store...

That a reader will scroll through the material to find advertising links is presumptuous. .. wishful thinking... a BIG leap of faith...

That a consumer …

    • will know, understand or assume that the content contains advertising links and,

    • will know exactly where to look to find the specific words or content that contain the relevant links...these are also presumptuous assumptions.

I know where the links are because I inserted the links and I can see them on my copy.

But, if the links are not readily identified or otherwise easily available and highlighted for the reader and/or prospective customer then I'm afraid all that hard work in creating content and fantastic product offers could loose the customer and result in lost conversions and sales...and what of the business?

Please tell me there is a solution and it doesn't involve yet another plugin or having to change the theme or having to pay someone beaucoup $$$ that I don't have...

Join the Discussion
Write something…
Recent messages
SydneyMac Premium
What font size are you using? When I use anything but “paragraph “ the change in color goes away and it no longer looks like a link.
Sydney
Reply
1Summer Premium
I've not changed the font size...except for using heading 3 for some of my headings on my content, otherwise, the font size is the same as that already on the program.

Though you do bring up an interesting point because the style of the fonts on the WP-admin is one thing, but when published it's a different font.
Reply
SydneyMac Premium
Hmmm. I had my fair share of frustration getting things to look just right as well. I eventually started suing DIVI and it’s made my life much easier. Not saying it will fix this but it helps getting the layout you want with less frustration. If you haven’t figured it out at this point tech support will know; they’re wonderful for figuring things out.
Reply
1Summer Premium
I'm not sure I know what "DIVI" may be...but for my original issue, I've managed to put on a nice dressing that I have a feeling will do the trick! So its all good...I'm moving on with the next lesson...

I'm going to looking into this "DIVI" that you've mentioned.

Thanks...cheers! :)
Reply
SydneyMac Premium
It’s a paid plugin. I think they’re sore is Divi.com if you want to know more.
Sydney
Reply
1Summer Premium
I will look into it...thanks.
Reply
RAFStuart Premium
My comments were going to be on the lines of the two below.
Reply
1Summer Premium
I'm wondering is anyone else or has anyone else experienced this issue before? I'm wondering those that have added Amazon links unto their content, are the links highlighted on the content that the reader sees?
Reply
1Summer Premium
I was going to post the two questions above, but it wouldn't let me post?
Reply
RAFStuart Premium
Not sure, have been having a problem getting the links on my site.
Reply
EandS2018 Premium
I would ask live help this question
Blessings
Reply
1Summer Premium
Thank you and blessings to you too ladies...

Cheers! :)
Reply
Vickic3 Premium
This might sound cheeky but / I have to ask- After you inserted the links in WordPress, did you click update?
Reply
1Summer Premium
Yup!
Reply
Top